City Engine 2013 - OBJ-Import failed

2515
6
03-21-2014 05:09 AM
by Anonymous User
Not applicable
Original User: SebastianLuhmer

Hello 3D-Folks,

i´m trying to import some obj-Files into City Engine 2013 and running into some issues. I copied the obj-Files into the assets folder into my City Engine Projekt. After choosing the option File->Import->OBJ File, browsing to a obj-File into the assets folder and clicking finish I get a warninig message (see the attatched screenshot).

The Log produces two error messages (see the other screenshot):

1. Unknown Rule
2. Asset reader failed! See error log. (IOExeption) - [main]


Does anybody have an idea what I have to do?

All the best.

Sebastian
0 Kudos
6 Replies
by Anonymous User
Not applicable
Original User: CC3Dinc

Hi,
I believe that is a bug with version 2013.  Some of my .obj files that worked for me version 2012 could not be imported into the 2013 version. (Also .dae and .kmz importation affected)
They are aware of this concern and are working on correcting it.
Best,
Scott
0 Kudos
SebastianLuhmer
New Contributor
CC3Dinc;375580


Hi Scott,

thanks for your answer. If the import of the 3 file-formats you have mentioned is buggy, lets hope that we dont´t have to wait for the 2014 version of the City Engine to long.  I am not familiar with City Engine 2012, but am wondering that the import of 3 more or less usual file-formats for 3D-Models does not work anymore in CE 2013.1.

Do you know a workaround to import OBJ-Files into City Engine 2013 another way.

Regards,
Sebastian
0 Kudos
by Anonymous User
Not applicable
Original User: matthiasbuehler

Hi,

I've taken a look ( in our daily build of CE ) at the files you sent.

One obj says "mtllib ./barn.mtl" on line 3. "./" is not yet supported, will be fixed. Just remove the 2 characters

The other obj crashes CE in the "Navigator Preview". We'll fix this for the release.


I hope I can give green light in the next couple of days on this..

Ok ?

Sorry for the inconvenience ..

Matt
0 Kudos
SebastianLuhmer
New Contributor
Hi Matthias,

thanks for your reply. Can you post here or pm me once there is a patch/hotfix for this OBJ-issue in CE 2013.1 or do you plan to fix this within the 2014 release?


Sebastian
0 Kudos
by Anonymous User
Not applicable
Original User: matthiasbuehler

Hi,

it's fixed and will be in CE 2014.

Ok ?

matt
0 Kudos
SebastianLuhmer
New Contributor
Hi Matthias,

thanks so far for the information and your support. I will be paitient an am waiting for the 2014 release.


All the best.

Sebastian
0 Kudos