center() rule

400
5
07-09-2012 06:06 PM
XuRukun
New Contributor
Hi,
I made some building blocks from points, then use center() rule to make sure the building???s center is the point ,but when the model imported into the ArcMap, found that the point is not in the center of the model.Of course, not all points are not in the center of the model.

[ATTACH=CONFIG]15898[/ATTACH]

Ladder-->
     s(5,50,10)
     r(0,-162,0)  
     center(xz)
    i("builtin:cube")

It is my rules ,and the picture shows the ploblem.I want to know the cause of the problem?
0 Kudos
5 Replies
MatthiasBuehler1
Frequent Contributor II
hi !

I'm not perfectly sure what you mean .. you mean the small value difference which is seen in your pic ?


possible issues :
1]
point featues are converted to tiny shapes ( about 2x2 cm ), so they basically 'lose' their 'point feature nature' in CityEngine since it does not yet have a native way to handle points. --> this may give you small errors in the cm-range.

2]
which export format are you using ?

3]
is your data geolocated ?


let me know, then I can explain a little more in detail based on your inputs.
0 Kudos
XuRukun
New Contributor
Hi,
The pic is a ArcMap screenshot;
I use more than 30 points test,and the maximum deviation nearly 50 centimeters(the width in that direction is 5 meters);
The export format is GDB file;
at last ,all my data is geolocated.
0 Kudos
MatthiasBuehler1
Frequent Contributor II
an other question : what file format did you use to export back to ArcGIS ?
0 Kudos
XuRukun
New Contributor
Direct export to FGDB which is supported by ArcGIS.
0 Kudos
MatthiasBuehler1
Frequent Contributor II
hmm.

this could indeed be a precision issue there. but we've reworked the FGDB exporter so it should work much better for 2012.

can you send me a test dataset ( PM ) so I can try to reproduce the issue here ?

let me know.
0 Kudos