Basemap to CityEngine best practice

5018
11
Jump to solution
08-20-2014 12:54 PM
KennethLindhardt
Occasional Contributor

I haven’t found a solution, on how to get basemaps into CityEngine smart! I don’t know if it’s not normal to export a basemap from ArcGIS, since I haven’t found a solution yet. What I do at this point.

Create my AOI, and cut my DTM to match. Then I’m not able to cut the basemap, so I’m actually using my AOI frame, to create a screenshot. That can not be the best way, and is defiantly not a great result.

0 Kudos
1 Solution

Accepted Solutions
deleted-user-1T_bOHag6M8d
Occasional Contributor

Hi Kenneth,

I turn off all other layers in ArcMap then export the basemap to a JPEG with the "Create World File" option checked. This creates a pretty decent georeferenced basemap image under 1MB that I can import into CityEngine.

View solution in original post

0 Kudos
11 Replies
deleted-user-1T_bOHag6M8d
Occasional Contributor

Hi Kenneth,

I turn off all other layers in ArcMap then export the basemap to a JPEG with the "Create World File" option checked. This creates a pretty decent georeferenced basemap image under 1MB that I can import into CityEngine.

0 Kudos
KennethLindhardt
Occasional Contributor

Thank you for that Nicholas. That was very useful. Much easier to actually create my AOI, than to clip in my layers from a polygon

0 Kudos
deleted-user-1T_bOHag6M8d
Occasional Contributor

Hi Kenneth,

Good to hear. I actually just posted a whole "getting started" tutorial that you might find interesting. It's geared towards my local users but the instructions can be modified for use by anyone/anywhere. Esri-CityEngine-tutorial/index.org at master · SJCGIS/Esri-CityEngine-tutorial · GitHub

0 Kudos
KennethLindhardt
Occasional Contributor

Thank you for sharing Nicholas!

0 Kudos
awei
by
New Contributor III

Hi Nicholas,

I used the same method but it's not georeferenced in CE. Any idea why?

0 Kudos
deleted-user-1T_bOHag6M8d
Occasional Contributor

Hi A Wei,

Make sure the ArcMap data frame you export the basemap from is in the same coordinate system that is used in CityEngine.

0 Kudos
awei
by
New Contributor III

Yes they are in the same coordinate system. Weird!!

0 Kudos
awei
by
New Contributor III

Did you add the basemap to CE in the same way as adding aerial image?

0 Kudos
deleted-user-1T_bOHag6M8d
Occasional Contributor

Does the exported JPG reference correctly when added to ArcMap? Maybe try creating a TIF or PNG with a world file instead.

0 Kudos