How to fix the default date on Quick Report apps?

1986
2
08-13-2015 12:17 PM
MattCashen1
New Contributor

My question relates more to the feature service you use when you create a quick report app. If you have a date field set up for your feature service then the default date in the app is always the current date. That would be fine, however, when the user doesn't change the date it becomes December 31, 1969 in your feature service. I know this has to do with Unix Time and that when the user doesn't go into the calendar the default date becomes 0(or December 31, 1969). While I do have a problem with that, I understand that's how its currently set up. My biggest issue is that by making the default date already set to the current date then the majority of users will not go into the calendar to reselect that date. So how can I make the date field blank or some arbitrary date that will implore more users to actually go into the calendar and set the date manually?

0 Kudos
2 Replies
DonaldHandshoe1
New Contributor II

I'm having the same issue. No one is going to enter the date if it is already displayed correctly on screen.

0 Kudos
MattCashen1
New Contributor

Exactly. I assume there has to be some way to change this within the coding. However, my knowledge of coding ranges from very little to none. So I was hoping someone could tell me what code to write and where to write it. Even though I know very little coding I have gone into the QT creator and looked at all the different pages of coding trying everything I can to make it work. No luck so far. I have been in contact with someone at ESRI tech support for a couple weeks now and he has yet to find the solution. Hopefully this is addressed in the next Beta.

0 Kudos