Hiding fields in Quick Report template

447
5
Jump to solution
10-02-2017 02:05 PM
Highlighted
New Contributor II

Working on a public facing quick report app and I have a hosted feature layer and I have created a hosted feature layer view that is configured to only show a select number of fields from the base hosted feature layer.  The QR 2.0 template still pulls all the fields as configured in the base hosted feature layer when the user pages to the add details page.  Is there a way to limit the fields that show on the add details page or do I just have to publish a feature layer with only the visible fields?

Reply
0 Kudos
1 Solution

Accepted Solutions
Highlighted
New Contributor II

The answer to this question is to use Hosted Feature Layer Views.  I was able to configure a HFLV with just the fields needed while having the full complement of fields available on the base HFL.  

Read about them here: http://www.arcgis.com/apps/Cascade/index.html?appid=1884d94a00074098add274c84c8209e2

View solution in original post

Reply
0 Kudos
5 Replies
Highlighted
New Contributor II

The answer to this question is to use Hosted Feature Layer Views.  I was able to configure a HFLV with just the fields needed while having the full complement of fields available on the base HFL.  

Read about them here: http://www.arcgis.com/apps/Cascade/index.html?appid=1884d94a00074098add274c84c8209e2

View solution in original post

Reply
0 Kudos
Highlighted
Occasional Contributor II

Creating and using a Hosted Feature Layer view made to change to the attributes visible in my AppStudio Quick Report project.

Reply
0 Kudos
Highlighted
Occasional Contributor II

Updated: Creating and using a Hosted Feature Layer view made NO to change to the attributes visible in my AppStudio Quick Report project. Updated

Reply
0 Kudos
Highlighted
by
Occasional Contributor II

So, Is it possible to hide the fields in Quick Report Template? I have used Feature View with View Definition and provided this feature service in quick report template but the fields are still visible. Any help?

Thanks,

Krish

Reply
0 Kudos
Highlighted
Esri Regular Contributor

Did you make sure to Reset the Quick Report app after the feature layer scheme is modified? https://community.esri.com/thread/245154-app-studio-quickreport-feature-layer-modified 

Reply
0 Kudos