AppStudio for ArcGIS iOS cloud make error ArcGIS.Framework.Controls depricated

1281
20
09-30-2020 09:32 AM
BrentSlone3
New Contributor III

Hi Team,

we have build an using AppStudio for ArcGIS (Desktop) quick reporter template. When we try using cloud build we are getting the following erorr:

Any suggestions would be helpful

Tags (1)
0 Kudos
20 Replies
ErwinSoekianto
Esri Regular Contributor

Ryan, that error message is just a warning. 

For MapViewer, you can remove them here. 

- MapViewer/views/SignInPage.qml line 9

- MapViewer/widgets/Icon.qml line 8

0 Kudos
RyanGay2
New Contributor III

Erwin, 

Thank you. Just a warning? So are you saying my app should have completed the build? Because it did not. 

0 Kudos
RyanGay2
New Contributor III

Erwin, 

Thank you. I modified the code as shown in your reply and had the same error Brent did. Failed without error message. 

0 Kudos
ErwinSoekianto
Esri Regular Contributor

Ryan, there seems to be an issue with our Cloud Make build system on iOS right now, we are looking at it. I will be in touch. 

0 Kudos
RyanGay2
New Contributor III

Understood. Thank you, Erwin. 

0 Kudos
ErwinSoekianto
Esri Regular Contributor

Ryan Gay‌ we have fixed the issue with the Cloud Make build system, all platforms should be working now. Let me know if you have any issues. 

RyanGay2
New Contributor III

Erwin, 

Thank you to your and your team for fixing those issues swiftly. I have been able to build the rest of my apps with no issues now. Thanks again!

0 Kudos
MervynLotter
Regular Contributor

I created an app using the Map Viewer template 4.3 early yesterday. I was then able to successfully create installation files for it later the day for both Windows (64 but) and Android devices. Not iOS. 

Today I needed to modify the settings to refer to a group instead of a single map, and now it can only successfully create the installation files for Android. It also fails with same error message as above  for Windows. See screen shot.  So the problem is not just with the iOS cloud make server it seems

0 Kudos
RyanGay2
New Contributor III

I actually got this same error trying to build for Windows as well today. I have not tried again since though. 

ErwinSoekianto
Esri Regular Contributor

Thank you for reporting this Mervyn, we are working on getting this fixed as soon as we can. 

0 Kudos