ArcGIS Pro Address Rematch Problem

1666
10
06-09-2020 03:17 PM
MVP Esteemed Contributor

ArcGIS Pro 2.5.1; Single Role Street Address Locator

I created a single role, street address locator and have been using it this afternoon, on a few tables.  Rematching worked just fine for the first few geocoded results, but this latest one is misbehaving.  Typically as I click through the unmatched addresses, I can make an edit to the address, hit the tab key, followed by the Apply button and get either suggestions or not.  Now, when I make the edit and then hit tab, apply, it kicks me back to the first record of the unmatched stack.  See gif below.  What is going on here?

10 Replies
Esri Regular Contributor

I'm not able to reproduce that behavior in 2.6 beta. Curious if you get the same when you geocode with zone as part of the address. If you are part of the beta program  you may want to test out some of your workflows in 2.6 beta.

MVP Esteemed Contributor

This might be a stretch but I think it has to do with the locator I used which is a published composite (10.8 address locators I believe). I used the service again today and the results were quirky, so I used a file based (not published) address locator and it worked well, and now weird behavior when rematching...

Reply
0 Kudos
Esri Regular Contributor

How many locators in the composite? ArcGIS Server 10.8?

Reply
0 Kudos
New Contributor II

Mine does that when I use a predefined query to filter those I want to rematch. It is really annoying. Was there a solution?

Reply
0 Kudos
Esri Regular Contributor

Does the behavior occur with a custom query as well vs the defined queries like 'Matched addresses with score below 80'? Are you also using the tab key without Auto Apply checked on?

Reply
0 Kudos
New Contributor III

@ShanaBritt @BrettStokes @ZacharySutherby I am also experiencing this issue and am using a file-based address locator in ArcGIS Pro. This issue causes our workflow to be much less efficient than it should be. Does this require me to propose a new idea to GeoNet?

Reply
0 Kudos
Esri Regular Contributor

What version of ArcGIS Pro are you using when reviewing the geocode results? Are you reviewing a selection of the geocode results? Is Auto Apply checked in the Rematch Addresses pane?

New Contributor III

@ShanaBritt Product Version: ArcGIS Pro 2.4.3 (Advanced, Concurrent Use license). 

Yes, I am reviewing a selection of the results, which are the most recent (the most recent Date field values). I have to retain all the records in the layer, so I do not use a Predefined Query from Rematch Addresses. The Auto Apply button is checked on in the Rematch Addresses pane. 

Reply
0 Kudos
MVP Esteemed Contributor

This thread is several months old and I've since migrated to 2.6 pro and only using the the new style locators with the create locator tool.  Sorry but I cannot remember what was going on here.

@PaulaMorrissey  and @JacobHelfman1  can you explain your  product version, workflows, locators etc  and the problems you are encountering in more detail?