-
DynamicMappingHost - Aktualisierung und Reparatur des Shared Service töten meinen Server
Enterprise 11.5. Soweit ich sehen kann, tötet der periodische Vorgang alle 30 Minuten, bei dem der Shared Service seine 'Periodisch prüfen und reparieren von Datenverbindungen für inaktive Instanzen' durchführt, meinen Server, da wir viele Dienste in der Shared-Instanz haben. Ich habe viele Dienste verschoben, die VRTs für…
-
Error Reconciling Branch Versioned dataset after upgrade to Pro 3.5
I have a script that reconciles all versions of our branch versioned data every night. Since upgrading to Pro 3.5 and Enerprise 11.5, that script started failing with an error of "The workspace is not the correct workspace type." I get the same error when trying to run the GUI version of the tool. Interestingly enough, the…
-
Statistics Returns 0 for newly published referenced feature services
Hello everyone, I am using Esri Dashboards to show some statistics, like the number of features in a layer (COUNT), and we use referenced feature services for that. Recently, the COUNT returns 0 for referenced Feature Services published within the last few days, while it works correctly for older referenced services. The…
-
Print service requiring login in Experience Builder app shared via distributed collaboration to ArcGIS Online
Hello everyone, We are experiencing an issue with the print service in a web map application deployed via distributed collaboration. Our environment and workflow are as follows: - Source: The web application is built and hosted using Experience Builder on ArcGIS Enterprise 11.5. - Distribution: The app item is shared via…
-
Restriction on publishing multiple services from a single data source
Hello, just got an update notice for ArcGIS Online below; "Prior to this update, organizations could publish multiple supported services from a single eligible source data item, creating a one-to-many relationship between source items and published services. To align with existing publishing restrictions, ArcGIS Online…
-
publish map image web layer without parent layer
I am published reference map image services to be added to a web map, using Enterprise 11.3 (an HA system, if that is relevant). When I publish reference map services, they are presented in two 'layers': the 'parent', which has the name I give in the 'Share As Web Layer' properties in Pro, and the 'child', which keeps the…
-
Where is my ImageServer WMTS URL ?
Hello everyone, I would like to create a WMTS service from a raster image published as an Imagery Layer. In ArcGIS Server Manager, I can see my Image Service. However, in the OGC Services tab, I cannot find its URL among the WMTS services. Yet according to ESRI: "Unlike other types of OGC services, there is no WMTS…
-
Why no starting and stopping of Map Services in Pro?
Why can't the starting and stopping of Map Services be built into ArcGIS Pro like they were in ArcCatalog? I know this has been requested of ESRI ever since ArcGIS Pro came out but what is their reasoning? It's inconvenient to administrators
-
What ArcGIS Server Utility & System Services can be stopped?
I have a multi-machine geocoding server setup with 5 ArcGIS Servers and a Web Adapter (linux machines). The server will only be running geocoding services. My question is whether disabling any of the Utility/system services that are running by default can improve performance? If so, what services are not used in geocoding…
-
Use of dynamic text tags in print layouts in an (custom) print service in ArcGIS Enterprise
Dear Community, I have a question about dynamic text tags in ArcGIS Pro and their use in print layouts in an custom print service in ArcGIS Enterprise. We are using ArcGIS Pro 3.5.4 and ArcGIS Enterprise 11.5. Specifically, we are using the dynamic text tags <dyn type="mapframe" name="Map Frame" property="metadata"…
-
Rebuild Spatial Index for Hosted Feature layers
Hello everyone, We are running ArcGIS Enterprise 11.5 and I am looking to automate the process of rebuilding spatial indexes for hosted feature layers. I am aware that this can be done manually through the Portal UI by going to the hosted feature layer item → Settings → Feature Layer (Hosted) → Indexes, where the spatial…
-
Publish service from Mapped Newtork Drive
Good Morning, Is it possible to publish referenced services in ArcGIS Enterprise 11.5 from Mapped Network Drives (E: for example)? Can the ArcGIS account access and manage them even if the Mapped Network Drive is only mapped for the user that is use the machine? Best regards
-
How to share Web Feature Layers to an Enterprise Geodatabase
Hi all, I am looking for guidance or documentation on a specific publishing workflow to share web feature layers to an Enterprise GDB in ArcGIS Enterprise system. Current setup: - ArcGIS Enterprise 11.5 (Server and Portal are federated) - Enterprise Geodatabase running on PostgreSQL - Note: We do not have an ArcGIS Data…
-
"Publish Geoprocessing Service" Pane Is Empty When I Attempt to Publish a Custom Python tool/script
Hi ESRI community, I'm working on publishing a geoprocessing service (Custom Python) to a standalone server (10.91). I'm able to run the tool in ArcGIS Pro ( v2.9), but after following these steps: 1. Right click the server connection with admin permissions --> Publish --> Geoprocessing Service 2. Select the successfully…
-
Do map or feature services read publishing ArcGIS Pro project file (aprx)?
A question came up today at my office asking whether ArcGIS Server map or feature services read or somehow access the ArcGIS Pro project file that was used to publish them on an ongoing basis. My understanding is that once they are published, they don't read or access the Pro project file, but I wasn't 100% sure. I am…
-
Change ownership for bulk published services - Unable to change owner
Hi folks, I noticed I'm unable to change ownership of items (Map Image and Feature Layers) that were bulk published. I'm trying to change ownership from one admin to another admin (both with the admin role). Getting a generic error: Unable to change owner IIRC, we could re-assign ownership of individual items (map image…
-
Delete corrupted hosted feature layer
A hosted feature layer in our organisation's ArcGIS Enterprise became completely corrupted following an attempt to overwrite it. I am now trying to delete it, however it is 'delete protected' and I cannot access the layer's settings page at all (see screenshot) to disable the deletion protection and delete it from there,…
-
Warning 24171 when overwriting a map image layer
When overwriting a map image layer that participates in multiple 1:M relationships and references registered data, I get the following warning: 24171: User assigned unique related IDs will not be honored I have not manually set any relate IDs. When I view the layer in a new map viewer, its 2 related tables are not present.…
-
datetime format in wfs service geojson format
hello ESRI team, I use the following url to perform wfs getfeature, the datetime field in xml is correct but geojson format is displaying dd/mm/yyyy, how can I change to dd/mm/yyyy.…
-
Publishing Image Service from Viewer Connection to Enterprise Database
I posted this in the Image Server community on Thursday but no replies yet; maybe this community is better suited to assisting on this topic? Original post in Image Server community ----- I cannot publish an image service to my Enterprise Portal from a Viewer sde connection to my database. I can publish the same imagery…
-
Best practices for custom basemaps in Portal (State Plane data, cache updates, and basemap gallery setup)
I’m am not really sure if we have “basemaps” set up in our organization is the best/most efficient way we have reference layers set up for our users. I am looking for some best practices and advice around building and serving custom basemaps for my organizaton in ArcGIS Enterprise Portal. My current setup is a published…
-
Controlling User Editing Access On Feature Services
The situation I’m currently facing is this: I manage the GIS for a small city, and we have a wide range of data that we’d like multiple non-GIS staff members to access. Our data is synchronized across all systems through feature services hosted by a third-party company (I do not have server admin access). We need the…
-
Hosted AGOL layer with stored credentials randomly fails to load in ArcGIS Enterprise 11.5 (Error 400 Bad Request)
After upgrading our environment from ArcGIS Enterprise 10.9.1 to 11.5, we started experiencing an intermittent issue when adding a secured hosted feature layer from ArcGIS Online (not public) to our Portal for ArcGIS as a new item with stored credentials. The item is successfully created and visible as a Feature Layer in…
-
Point Layers Failing to Sync Across a Distributed Collaboration
I am supporting a workflow where we are sharing content from ArcGIS Enterprise to AGOL via a distributed collaboration and I'm seeing strange behavior where we can share line and polygon layers but not point layers. Our data is in a SQL Server Enterprise Geodatabase. It is NOT versioned so we have archiving, editor…
-
Getting Failed to obtain item from data store for given id: () error on everything
We keep getting this error " Failed to obtain item from data store for given id: ()" on all our services. We have tried every kind of way to publish we can think of. No errors on the publish. Tried from sde connections (OSA and default version), added to database section, you name it. Its all our services. Even very simple…