Select to view content in your preferred language

Geodatabase not compatible with older versions?

217
5
a month ago
Scosh
by
New Contributor II

I just updated to 3.3.0 and now a client is unable to view my geodatabase with ArcMap (v. 10.8.2), ArcGIS Pro (3.1.2) or ArcCatalog (10.8.2).

Anyone else have this?

0 Kudos
5 Replies
RyanUthoff
Regular Contributor

When you upgraded, did you upgrade the geodatabase to a 3.3 database as well? Alternatively, is this a new geodatabase you created after you upgraded to 3.3?

0 Kudos
MichaelVolz
Esteemed Contributor

What kind of geodatabase can be upgraded in 3.3 (all geodatabases including file geodatabases or just enterprise geodatabases)?

0 Kudos
RyanUthoff
Regular Contributor

I was referring specifically to enterprise geodatabases. Not sure about file geodatabases.

0 Kudos
valenj88
New Contributor III

This likely has to do with the new datetime high precision field type found here: High Precision Date Field Issue when Registering T... - Esri Community

0 Kudos
BrianFausel
Occasional Contributor III

It is possible to upgrade enterprise and file geodatabases, though it would be to whatever Enterprise equivalent that Pro 3.3 is (looks like Enterprise 11.3). I would think a geodatabase created in 11.x will not work in ArcMap. If the geodatabase was not upgraded, I have had issues opening layers in ArcMap if you set up newer Pro-related functionality (attribute rules, for instance). Once you remove the advanced functionality then the layer works in ArcMap again.

0 Kudos