Select to view content in your preferred language

Field Map tutorial that uses EGDB feature service layer

307
13
4 weeks ago
dsinha
by
New Contributor II

Hello,

I am trying to create a Field Map app for my organization for data collection. I want the app to use a feature service generated off a feature class in the organization's EGDB. Are there any tutorials/demo videos/webpage where there are instructions of how to go about doing this?

I am the DB and EGDB admin for my organization but I keep getting error messages in the  Forms dialog box essentially indicating that I do not have edit permission on the feature service and all the form elements are greyed out.

Any help would be appreciated.

Thanks,

Deb.

0 Kudos
13 Replies
drWood
by
New Contributor III

https://fwp-gis.mt.gov/arcgis/help/en/field-maps/android/help/prepare-an-editable-layer.htm This resource might help guide you in the right direction. There are a couple instructor-led courses that have in-depth material on this topic as well.

0 Kudos
HannesVogel
New Contributor III

https://pro.arcgis.com/en/pro-app/latest/help/sharing/overview/configure-web-feature-layer.htm 

in the ArcGIS Pro documentation there is also great explanations 

0 Kudos
dsinha
by
New Contributor II

Thanks @drWood and @HannesVogel! I have tried to follow those instructions but not having any luck so far. I will keep trying. I am sure there is some setting somewhere that I have not discovered.

0 Kudos
HannesVogel
New Contributor III

did you activate "Feature" in the share as web layer dialg?
HannesVogel_0-1716990983262.png

then go to the Configuration Tab and click the pen-icon

HannesVogel_1-1716991112232.png

then enable the editing options you want to allow the editors:

HannesVogel_2-1716991199448.png

then publish and add the featureservice to your webmap. At which point occurs a problem on your side?

 

dsinha
by
New Contributor II

Thanks @HannesVogel! Yes, I did all activate those settings. The problem happens when I open the layer in the Field Map Form Builder. I get errors indicating that I have not set up the properties correctly (see attached screenshot) and I am not able to design the form or save it.  

HannesVogel
New Contributor III

Thanks @dsinha I cannot replicate that on my side. What is your layer you want to work on - is it maybe in the WFL1 Group/service? I always publish the referenced featureservices first and then add the published service to a map and save the map instead of publishing data and saving the map in one combined step.

dsinha
by
New Contributor II

@HannesVogel the layers under the WF1 Group are only there for reference. No data would be added or modified to those layers. Those are hosted feature layers. The FieldDataCollection layer is the feature service that would be edited. Thanks for working with me on this!

0 Kudos
HannesVogel
New Contributor III

another question - did you maybe disable popups for the layer(s)? As far as I understand, you need popups that you also convert to a form in Field Map but you don't need to, but maybe if you disable popup Field Maps cannot handle it.

0 Kudos
dsinha
by
New Contributor II

I do not know where to check for this setting. Could you please guide me?

0 Kudos