Not able to Publish Geodatabase from Arccatalog or Arcgis online Manager

269
4
Jump to solution
05-23-2012 10:43 AM
prashantpal
New Contributor II
Hello,

Please help me out with this. I am trying to set up ArcGIS 10 server on local machine and am using ArcSDE Microsoft SQL Server 2008 for database.
I am trying to publish a Geodatabase using Arccatalog and ArcGIS online Manager but both are giving this following error.

Error when I try to publish it using Database connections.

Configuration Geoadmin.GeoDataServer can not be started.
Server Object instance creation failed on machine usf-960-1-win7.
Unable to init from C:\Users\prashantpal\AppData\Roaming\ESRI\Desktop10.0\ArcCatalog\Geoadmin_connect.sde.

Error when I try to publish it using GDB itself.

Configuration Geoadmin.GeoDataServer can not be started.
Server Object instance creation failed on machine usf-960-1-win7.
Unable to init from C:\Users\prashantpal\Desktop\Try\try.gdb.

Logs

<Msg time='2012-05-23T13:35:27' type='ERROR' code='90004' target='Geoadmin_connect.GeoDataServer' methodName='GeoDataServer.Construct' machine='USF-960-1-WIN7' process='3828' thread='1280'>Unable to init from %s.</Msg>
<Msg time='2012-05-23T13:35:27' type='ERROR' code='1016' target='Geoadmin_connect.GeoDataServer' machine='usf-960-1-win7' thread='3872' elapsed='0.16000'>Server Object instance creation failed on machine usf-960-1-win7.   Unable to init from C:\Users\prashantpal\AppData\Roaming\ESRI\Desktop10.0\ArcCatalog\Geoadmin_connect.sde.  </Msg>
<Msg time='2012-05-23T13:35:27' type='ERROR' code='1008' target='Geoadmin_connect.GeoDataServer' thread='6224'>Configuration Geoadmin_connect.GeoDataServer can not be started.</Msg>

I have included ArcGISSOM and ArcGISSOC users to access these locations, but still it couldn't resolve this problem. I think its a mistake with my configuration , please help me resolve this problem.

Thanks
Prashant Pal
0 Kudos
1 Solution

Accepted Solutions
prashantpal
New Contributor II
Thanks for replying Domenico

This problem came for both Mapserver and Geodataserver. I made a mistake of not giving the GDB/MXD file the required
permissions (ie ArcGISSOC & ArcGISSOM).

Thanks again :)

Pal

View solution in original post

0 Kudos
4 Replies
nicogis
MVP Frequent Contributor
Have you problem only with GeoDataServer or also with MapServer?
0 Kudos
prashantpal
New Contributor II
Thanks for replying Domenico

This problem came for both Mapserver and Geodataserver. I made a mistake of not giving the GDB/MXD file the required
permissions (ie ArcGISSOC & ArcGISSOM).

Thanks again :)

Pal

View solution in original post

0 Kudos
BrendanBladdick3
Esri Contributor

What did you give permissions to precisely to get this to work? I am a little confused on what specifically you granted permissions to and what user that you granted those permissions to. Any response would be much appreciated

0 Kudos
nicogis
MVP Frequent Contributor
Well. However you need only for user arcsoc
0 Kudos