Multiple errors while creating Tile Package

459
6
07-14-2021 09:14 AM
Labels (2)
ssgordon
New Contributor II

I've been trying to create a tile package for a few maps for awhile. Unfortunately, throughout the process Arcmap has stopped running frequently (a quirk of my organization). When this happens I've used Manage Tile Cache as a way to resume packing the empty tiles. So far I thought this was working, but today I ran it again and came across a whole bunch of errors.

When I run Manage Tile Cache I get:

Error 001518: Failed to build tile cache for feature with OID = 0

Error 999999: Error executing function

Error 001517: Failed to generate tiles for (map path)

Error 001143: Background server threw an exception

 

I also ran Export Tile Cache to get another read on the situation and got even more:

Error 001473: Failed to export cache for every scale in the package

Error 001485: Failed to create tile package

 

If anyone has any idea how to fix this error so I don't have to restart my packaging that would be great! Any advice on resuming a crashed tile package tool would be great too.

0 Kudos
6 Replies
DavidPike
MVP Frequent Contributor

in Manage Tile Cache you could simply run the tool again but for only the scales you need to redo (go into the cache folder structure and delete the existing bundles for the crashed level e.g. L0, L01 etc. first) or is it the final scale level which keeps erroring-out? (also think about parallel processing factor to get it done faster).

0 Kudos
ssgordon
New Contributor II

Unfortunately I'm not getting errors for specific scales except in Export Tile Cache, where I get errors for every scale. I may still take a look into the cache folder structure and see if I can find any errors there. Fortunately, I have been parallel processing on 3 instances, it's just a huge area so it takes several days. 

0 Kudos
DavidPike
MVP Frequent Contributor

Actually doesn't manage tile cache have an option to create only missing tiles? After re-reading your initial post, why are you getting a server error related to this tool?  Is the data sat on that server and can you just run it on the server machine?

What are you hoping to achieve with export tile cache?

0 Kudos
ssgordon
New Contributor II

It does, and that is the option I am using. I used export tile cache to try and get a Tile Package file I could look at to see where my missing tiles were; I only had a tile cache and not a tile package. 

I'm running this tool using server data with ArcMap running remotely on a server, I expect that's why I'm getting a server error. 

0 Kudos
DavidPike
MVP Frequent Contributor

The tile cache will be available to view in arcmap or catalog natively without needing to export. I would turn off background geoprocessing if you have it enabled, as the error message seems to be related to it in some instances (worth a go).

Jordan
by
New Contributor II

For Error 001518 - one thing I just managed to resolve with one of my AOIs that was throwing this error was:

The mosaic I was using to build the cache was a mosaic comprised of multiple mosaics and in this specific area, two separate underlying mosaics had raster's in them that were within this AOI. However, only one of those mosaics had a raster that matched the entire AOI boundary, where as the other ones raster was only partially within the AOI (think separate raster's that cross over a state border).

In this case, I specifically ran the tool using the underlying mosaic that matched the AOI as the input data source and it built fine. My guess is that it was trying to read the data from the other mosaic in the original build and wasn't happy because the raster's didn't fit the AOI.

0 Kudos