Public comments in ArcGIS Urban cannot be stored

417
3
Jump to solution
11-01-2020 03:01 PM
Yann-EricBoyeau
Occasional Contributor

Hi,

We are currently trying to store public comments in ArcGIS Urban without success.

1) We configured Urban to allow public comments

2) We already have an Hub Annotations feature layer needed to store public feedback

3) When a public comment is added in Urban interface, the response to the corresponding "addFeatures" request is :

"success":false,"error":{"code":1000,"description":"Cannot insert the value NULL into column 'author', table 'db_5199.user_5199.Hub_Annotations_HUB_ANNOTATIONS'

Hub annotations feature service is managed by ArcGIS hub : by design, there is no default value for "author" field, and Null values are not allowed. Behaviour is the same if logged in AGOL.

So we are currently unable to have this useful feature working in ArcGIS Urban. Provide feedback—ArcGIS Urban | Documentation 

Did anyone manage to have this working properly ?

Thanks,

Yann-Eric

0 Kudos
1 Solution

Accepted Solutions
DominikAllemann
Esri Contributor

Hi Yann-Eric Boyeau‌,

Thanks for your question. I'm sorry to hear that the public feedback feature of ArcGIS Urban is not working as expected in your case. 

The data model of Hub Annotations layers was slightly changed before the first release of ArcGIS Urban in July 2019. Based on the screenshots you've shared it looks as if your Hub Annotations layer was already created in 2018 - i.e. it doesn't include yet the Urban specific changes to its data model.

As an immediate solution, you could consider one of the following workarounds:

  • Delete and re-create Hub Annotations layer
    • In the Urban data manager, set "Public Engagement" to disabled.
    • Delete the current Hub Annotation layer.
      • To prevent data loss you would need to create a data backup before deleting the layer.
    • In the URban data manager, set "Public Engagement" to enabled.
      • This automatically creates a new Hub Annotation layer that follows the updated Hub Annotation layer schema.

  • Add missing fields to existing Hub Annotations layer
    • Sign in to ArcGIS Online as an administrator.
    • Locate the Hub Annotations Layer.
    • Add the missing fields to the layer - the screenshot for the complete list of fields of the Hub Annotations Layer.

Have an excellent day 🙂

-Dominik

View solution in original post

3 Replies
DominikAllemann
Esri Contributor

Hi Yann-Eric Boyeau‌,

Thanks for your question. I'm sorry to hear that the public feedback feature of ArcGIS Urban is not working as expected in your case. 

The data model of Hub Annotations layers was slightly changed before the first release of ArcGIS Urban in July 2019. Based on the screenshots you've shared it looks as if your Hub Annotations layer was already created in 2018 - i.e. it doesn't include yet the Urban specific changes to its data model.

As an immediate solution, you could consider one of the following workarounds:

  • Delete and re-create Hub Annotations layer
    • In the Urban data manager, set "Public Engagement" to disabled.
    • Delete the current Hub Annotation layer.
      • To prevent data loss you would need to create a data backup before deleting the layer.
    • In the URban data manager, set "Public Engagement" to enabled.
      • This automatically creates a new Hub Annotation layer that follows the updated Hub Annotation layer schema.

  • Add missing fields to existing Hub Annotations layer
    • Sign in to ArcGIS Online as an administrator.
    • Locate the Hub Annotations Layer.
    • Add the missing fields to the layer - the screenshot for the complete list of fields of the Hub Annotations Layer.

Have an excellent day 🙂

-Dominik

View solution in original post

Yann-EricBoyeau
Occasional Contributor

Dear Dominik,

Deleting and recreating Hub Annotation layer solved the issue.

Thank you for your precise and helpful answer. 

We have great time using and discovering ArcGIS Urban functionalities !

0 Kudos
DominikAllemann
Esri Contributor

Hi Yann-Eric Boyeau,

That's great news that recreating the Hub Annotations layer solved the issue.

Thanks for your positive feedback :-).

-Dominik