Survey123 Adding Fields to Nested Repeats

257
2
08-19-2021 08:04 AM
IFI
by
New Contributor II

Hi,

I am having problems when trying to add fields to an already published survey. I am trying to add a field (highlighted in red in the attached jpg) in a repeat which is nested within another repeat. I know that you need to add a field inside the parent and child, but I cannot figure out how to implement this in this case. I know I could add temporary rows, then republish, then delete the temporary fields then publish again, but I cant figure out where to put the temporary rows.

Any help would be greatly appreciated.

Thanks,

Paul

 

0 Kudos
2 Replies
AllisonHollier
New Contributor III

Is the survey working in connect, you're just not able to publish it?  

The reason I ask is, I was under the impression that you could not add a field to an already-published in-use survey because it will change the schema.  

Please someone correct me if I'm wrong, but I'm almost positive that's what my ESRI rep told me.    

0 Kudos
IFI
by
New Contributor II

Hi Allison,

Yes it is working in connect, but hangs when I try and publish the updated version.

As far as I am aware you can add fields to an already published survey, I have done so in the past anyway! I think if you change existing questions (i.e. changing the field types from integer to strings) you can run into problems.

My problem is that I am adding a question inside a nested repeat and I am trying to figure out where to put the "dummy question". https://community.esri.com/t5/arcgis-survey123-questions/hanging-when-trying-to-publish-update-to-su... 

Thanks,

Paul

 

 

 

 

0 Kudos