Multiline Photo Only Allowing One Photograph in Web Form

463
4
Jump to solution
03-30-2021 06:56 AM
ACCDVermont
New Contributor II

I have survey set up that uses the photo field type with the multiline appearance to allow users to attach up to five photographs with their survey entry. The photo "question" works well in the Survey123 app and in Survey123 Connect but in the Web Form the survey only allows for one photo attachment and doesn't allow for additional photos to be added beyond the first photo. I have published the survey with Survey123 Connect 3.12 and used the photo count constraint described in this blog post to limit the number of photos to <6.

This is how the multiline photo question appears in the web form. I expected after the first photo was attached that a new row/prompt would appear to allow for the next photo to be attached like in the Survey123 app, but I do not see how a user could attach an additional photo.

ACCDVermont_0-1617112269953.png

I am curious how to fix this. A screenshot of how I have the xlsx form set up for these fields is below. I also have body::esri:style field set to method=camera,browse

 

ACCDVermont_1-1617112497719.png

 

0 Kudos
1 Solution

Accepted Solutions
Philip-Wilson
Esri Notable Contributor

Hi @ACCDVermont,

Further to my comment above, it looks like there is a known bug with using constraints on multiline images in the web app. It all depends how you have constructed the expression, and there appears to be a workaround.

Please refer to https://community.esri.com/t5/arcgis-survey123-questions/cannot-add-multiple-photos-in-web-form-with....

And currently this issue is planned to be resolved in the next release.

Regards,

Phil.

View solution in original post

4 Replies
Philip-Wilson
Esri Notable Contributor

Hi @ACCDVermont,

Yes, the multiline apperance for image questions is supported in the web app. Which version was your survey originally published with? Out of curiosity, do you have version locking enabled, and if so, this may be the problem. The survey needs to be open in the latest version (at least 3.12 I think) for the multiline appearance on image questions to work in the web app.

Philip-Wilson_1-1617928506216.png

 

Once version locking is off, or your survey shows as being publsihed in the latest version, you should see the image question with multiline appearance as follows in the web app. After adding the first image from the camera, I see a count and another prompt to add another image:

Philip-Wilson_0-1617928414756.png

Note that using the method of camera or browse in the xlsform only applies to the field app, not the web app. If you want to attach images from file browser in the web app, you can use an file question type.

Regards,

Phil.

0 Kudos
Philip-Wilson
Esri Notable Contributor

Hi @ACCDVermont,

Further to my comment above, it looks like there is a known bug with using constraints on multiline images in the web app. It all depends how you have constructed the expression, and there appears to be a workaround.

Please refer to https://community.esri.com/t5/arcgis-survey123-questions/cannot-add-multiple-photos-in-web-form-with....

And currently this issue is planned to be resolved in the next release.

Regards,

Phil.

ACCDVermont
New Contributor II

Thanks Phil! That bug is what I was running into with the photo constraint. The work around worked for me. Thank you

ZhifangWang
Esri Regular Contributor

Hi @ACCDVermont ,

This issue (BUG-000138683) has been fixed in the September 2021 release of Survey123 (version 3.13). To utilize the fix, you need to republish the survey in Survey123 Connect 3.13 or turn off the version lock of the web app.

 

Thanks again for your feedback.

0 Kudos