Calling Survey123 from Collector and editing record

613
5
12-19-2019 06:10 AM
KitJones
New Contributor

I am looking to edit data created with Collector with Survey123 using a custom URL.  From this thread it does not appear this is currently possible Edit existing data in Survey123 Form from Collector using custom url?  

Users will not be connected to the internet while collecting data so it does not appear the this work around will work Survey123 Tricks of the Trade: Editing records in a web form 

Accessing the record from the Inbox is not a feasible option given the number of records and the pace they need to be recorded.  Users will be navigating using Collector, so the record has to originate there. However the data types we need to collect are available only as a Survey123 form.

Are there currently any workflows to make this happen?

0 Kudos
5 Replies
DougBrowning
MVP Notable Contributor

We have a workflow to create new forms each time instead of editing.  Have a Key in Collector that passes to 123.  Then relate all the forms using that Key back to the original point.  This way you have a change log, full editor tracking, etc.  

0 Kudos
KitJones
New Contributor

I’ve tried passing the Global ID to collector to accomplish this but when I try to publish a form in Survey123 I get the message “The custom feature service submission url is not compatible with this survey (Field not found in the feature service:1)”

I’m using the steps outlined here: https://community.esri.com/thread/208613-pass-global-id-from-collector-to-g#

0 Kudos
JamesTedrick
Esri Esteemed Contributor

Hi Kit,

It sounds like there is a question or note present that is not present in your feature service.  You will need to compare the list of fields with the list of questions to identify it; if it's a note, you can remove the name entry (assuming you do not use it in calculations); if it's a question and you do not need to store its answer, you can give it a null EsriFieldType.

0 Kudos
KitJones
New Contributor

Hi I was wondering if you had a chance to look at this? Still not able to add the guid fields without getting the error preventing the survey upload

0 Kudos
JamesTedrick
Esri Esteemed Contributor

Hi Kit,

To identify the specific questions causing the issue on publishing, you need to compare the list of questions with the list of fields - that is something that I would not be able to do without access to both.

0 Kudos