Mobile Map Package Version Is Not Supported

769
7
Jump to solution
02-27-2019 10:05 AM
KyleGruber
Occasional Contributor II

Getting an exception when trying to load an MMPK I just created from ArcGIS Pro.

Esri.ArcGISRuntime.ArcGISRuntimeException: 'Mobile map package version is not supported.: Mobile map package version not supported : 3.0'Esri.ArcGISRuntime.ArcGISRuntimeException: 'Mobile map package version is not supported.: Mobile map package version not supported : 3.0'

Having no problems with MMPKs created 2-3 months ago.

ArcGIS Pro v2.3.1

ESRI.ArcGISRuntime v100.4.0.0

EDIT:  Upon further research, it appears that using the Create a Locator geoprocessing tool causes the MMPK version to be updated to 3.0.

Tags (2)
0 Kudos
1 Solution

Accepted Solutions
MarkBockenhauer
Esri Regular Contributor

Kyle,

Yes, the new locator files as well as Tile Package .TPKX will create Version 3 Mobile Map Packages.  Version 3 is supported in Runtime 100.5... due to release soon.

Mark

View solution in original post

7 Replies
MarkBockenhauer
Esri Regular Contributor

Kyle,

Yes, the new locator files as well as Tile Package .TPKX will create Version 3 Mobile Map Packages.  Version 3 is supported in Runtime 100.5... due to release soon.

Mark

View solution in original post

KyleGruber
Occasional Contributor II

Thanks for the confirmation Mark!

0 Kudos
JohnFix2
New Contributor III

I have been creating mobile map packages with ArcGIS Pro for runtime 100.5/6 and I was under the impression I have to use ArcMap's "create runtime content" so the locators would have the ".locb" file. That the ".locb" file was needed for runtime. Is this no longer the case? At which runtime was this changed?

I can not make mmpk in ArcMap since I use a vector tile cache.

Thanks!

John

-would love to remove ArcMap from the MMPK creation process.

0 Kudos
MarkBockenhauer
Esri Regular Contributor

John,

Using ArcGIS Pro to create Mobile Map Package (MMPK) that include locators (.loc) output from Create Address Locator tool has been supported since Runtime 100.2

You mention that you are targeting Runtime 100.5/6,  ArcGIS Pro is capable of creating a new version  of locator (.loz) from the "Create Locator" tool, these are not supported in 100.5/6.   The version of the Mobile Map Package will be incremented to a version that is not supported by the apps built on the 100.5/6 runtime if the new locators are inside.

,,, also feature search can also be a good alternative to locators if it works for your use case.

Mark 

0 Kudos
JohnFix2
New Contributor III

Mark,

In a previous thread, I was told that locators created in ArcGIS Pro with the new Create Locators would only work in 64bit applications. If the mmpk was deployed to other devices (iOS or Android) or a 32bit PC, the locator would not work. Can you confirm this has changed?

https://community.esri.com/message/900323-re-local-locators-not-working-in-1007?commentID=900323#com... 

By bniemand-esristaff 

Thanks.

-John

0 Kudos
MarkBockenhauer
Esri Regular Contributor

John,

You had mention that you were using ArcMap.  The "Create Address Locator Tool" in ArcGIS Pro creates locators that are similar in nature to ArcMap with the same capabilities.

The "Ceate Locator" tool that you mention does create new locators, and they can be used with runtime 100.8 on 32 bit hardware.  Not a solution for your runtime 100.5/6 applications.

Mark

0 Kudos
JohnFix2
New Contributor III

No problem updating to 100.8, we we're told about this problem at 100.6 trying to move to 100.7.

It's not an issue with the "create address locator" command in ArcMap vs ArcGIS Pro, it's that ArcMap "Create Runtime Content" is the only command that makes the ".locb" that is, or was, needed by runtime on non- 64bit apps.

We will update our project to 100.8 and use ArcGIS Pro to create the mmpk with "create locators". Will be such an easier work flow.

Thanks Mark.

John

0 Kudos