Integration error showing on arcgis.runtime.toolkit but it is present in packages folder?

918
6
10-29-2020 04:30 AM
HarshGupta
New Contributor II

Michael Branscomb

#runtimesdk.net

Hi sir

 I run my GIS project standalone it is working fine.But

When i integrate my gis application to an existing project it is showing me exception that 

(System.Windows.Markup.XamlParseException: ''The invocation of the constructor on type 'Esri.ArcGISRuntime.Toolkit.Preview.UI.Controls.TableOfContents' that matches the specified binding constraints threw an exception.' Line number '123' and line position '22'.') and inner exception is(FileLoadException: Could not load file or assembly 'Esri.ArcGISRuntime, Version=100.4.0.0, Culture=neutral, PublicKeyToken=8fc3cc631e44ad86' or one of its dependencies. The located assembly's manifest definition does not match the assembly reference. (Exception from HRESULT: 0x80131040))

but inside package folder toolkit 100.4.0 and toolkit.preview 100.4.0 both are available and i m using esri.arcgis.runtime 100.6.0

sir please  please help me out  sir i m badly stuck here.

0 Kudos
6 Replies
MichaelBranscomb
Esri Frequent Contributor

Hi,

It seems your Toolkit v100.4 reference is trying to find the API v100.4 but instead probably finds the API v100.6 which you say you have also referenced. It would be beneficial if you could provide more details of your project/solution structure. You may also want to try Stack Overflow since this could be more of a general reference management issue.

Note the current releases of the API and Toolkit are v100.9. 

Thanks

Mike

0 Kudos
HarshGupta
New Contributor II

Michael Branscomb

Hi Sir,

If Toolkit v100.4.0 was finding esri.arcgisruntime 100.4.0 then it should also not worked in standlone mode.

but it is working in standalone and not working on Integrated mode.

I am stucked please help me out.

i attached screenshot of App.config, packages.config,Packages folder.

App.config

App.configpackage.config

Packages folder

 

ArcGIS Runtime SDK for .NET

And it is continously showing me error ''The invocation of the constructor on type 'Esri.ArcGISRuntime.Toolkit.Preview.UI.Controls.TableOfContents' that matches the specified binding constraints threw an exception.' Line number '123' and line position '22'.') and inner exception is(FileLoadException: Could not load file or assembly 'Esri.ArcGISRuntime, Version=100.4.0.0, Culture=neutral, PublicKeyToken=8fc3cc631e44ad86' or one of its dependencies. The located assembly's manifest definition does not match the assembly reference. (Exception from HRESULT: 0x80131040)).

Please help me..

0 Kudos
HarshGupta
New Contributor II

Michael Branscomb

How to update toollkit from 100.4.0 to 100.6.0 in manage nuget package it is  showing me option for  updating

0 Kudos
dotMorten_esri
Esri Frequent Contributor

I'd recommend you always keep your runtime version and your toolkit version the same. Having 100.4 with 100.6 is not recommended.

However you could try and checking the assembly redirect in the project settings, and it should likely load for you:

0 Kudos
HarshGupta
New Contributor II

@Morten Nielsen

Michael Branscomb

But in 100.6.0 toolkit  table of content is not working(not displayed the content) properly it is working fine in 100.4.0 toolkit.

And i need arcgisruntime 100.6.0 because kml export funtinality introduce in 100.6.0.

so i m consufed what to do.

0 Kudos
dotMorten_esri
Esri Frequent Contributor

What issues are you having with the toolkit TOC? Also the toolkit is open source - you can pull the source for any version and recompile it for your version, and make any adjustments you like. GitHub - Esri/arcgis-toolkit-dotnet: Toolkit for ArcGIS Runtime SDK for .NET 

0 Kudos