Blog discussion - GeoAI toolbox (AutoML and Text Analysis tools in ArcGIS Pro 3.0)

265
11
08-31-2022 07:32 AM
Labels (1)
NicholasGiner1
Esri Contributor

We recently released two blogs discussing the new GeoAI toolbox in ArcGIS Pro 3.0.  

This discussion is for questions related to the blogs or the tools themselves, or to share how you are using these tools or any feedback you have on them.  

0 Kudos
11 Replies
KManl
by
New Contributor II

Hi,

Quick question:

I am training using autoML and have successfully done this before with the tool, but now the training tool will not work. Every time I try to train the tool shows me it is processing features, and then gets stuck at the same point every time and eventually fails. I have identified that it is getting stuck processing the one training distance feature. I have tried repairing the geometry, redownloading the data, etc. but nothing helps it always gets stuck at the same point of processing. This is also weird because I have used this exact same data for training a distance feature previously and have changed nothing. it just doesn't work now. Any help would be amazing, thank you.

0 Kudos
NicholasGiner1
Esri Contributor

Hi @KManl, thanks for the question.  So you've used the Train Using AutoML tool successfully, and it just started not working?  If you remove the one problematic training distance feature, does the tool run successfully?

0 Kudos
KManl
by
New Contributor II

Hi @NicholasGiner1,

I have fixed the issue now. But I have run into a new one. I am running the autoML tool to predict species richness (predict to raster) based on all 19 bioclimatic variables (rasters). When predicting for much different future scenarios the prediction result is always the same even though the model inputs are different for each scenario (i.e. under different future climate scenarios). What am I doing wrong here?

Thank you for your help.

0 Kudos
PriyankaTuteja
Esri Contributor

@KManl Could you provide data and steps to reproduce the issue?

0 Kudos
jiewilliam
New Contributor

Hello, I want to ask why I put grid data in the training grid to explain that the dataset does not exist or is not supported.

0 Kudos
PriyankaTuteja
Esri Contributor

@jiewilliam  Could you provide data and steps to reproduce the issue?

0 Kudos
jiewilliam
New Contributor

First of all, thank you very much for your reply. I have solved the above problems. But I have a new question to ask you. When I use AutoML to predict, why will memory continue to grow, leading to the final software flash back? At the same time, I also use pychar's arcpy to try this data, but still encounter the problem of memory continue to grow, leading to software flash back. My running memory is 16G, with 3060 gpu and i5-12450 cpu.I don't know if it's my software settings. When running programs, the utilization rate of CPU and gpu is very low, but the memory has been growing.

0 Kudos
PriyankaTuteja
Esri Contributor

What are the total number of records In prediction set ? Do you see this behavior while predicting even when the number of records is small ? Or does it happen when number of records exceed a specific number ?

0 Kudos
jiewilliam
New Contributor

That happens when the number of samples is 31488499. When I reduce the number of samples to 85555, it can run normally.

0 Kudos