ArcGIS Pro 2.8 Georeferencing: raster (temporarily) disappears after moving

945
3
Jump to solution
06-09-2021 04:57 PM
Labels (1)
BryanWright
New Contributor III

I've seen a few similar posts to this issue but mine is a little different and none of the work arounds I've seen have worked for me. 

I have many aerial photos (.jpg) with accompanying world files (.jgw) based on the plane's GPS coordinates that I'd like to add to a map and then subsequently move around (georeference) to new locations.  No control points are involved--they are oblique images and I'm not overly concern about their true location (relative is good enough).

Here are the steps I'm using:

I open a new project and set the map coordinate system to "WGS 84" to match the world file.  Then I "Add Data" to select an image.  At this stage I've done this 1) with and without building pyramids, 2) with and without calculating statistics, and 3) with and without the checkbox in the raster options where it says "Use world file to define coordinates to the raster".

Next I select the image in the "Contents" pane and then select the "Imagery" tab.

Then I select the "Georeference" tab and then the "Move" icon.  I then move the image to a new location, select "Save", and then "Close Georeference". 

At this point, as soon as I hit close the image disappears!!

If I "Zoom to layer" on the image the map shifts to the new location but nothing is visible.  However, if I repeat the above Georeference steps (i.e., move, save, close) on the same (or another image) one or sometimes two more times then the image finally appears in its new location and I can move on.  But this is time consuming and cumbersome as I have hundreds of images to process like this.  I had the same workflow in ArcMap for years and it worked quickly and perfectly there.

I've attached a sample picture and .jgw file if you want to try it yourself.  The .jgw extention is renamed to .txt in order to upload--just change it back.  Also I realize the image is over land and the .jgw puts it over water--it's just a fake example.  Thanks for any suggestions!

 

0 Kudos
1 Solution

Accepted Solutions
BryanWright
New Contributor III

Just wanted to follow-up that Esri tech support was able to confirm that the behavior I was encountering was indeed real but it didn't quite rise to the level of a bug since it seemed localized to my particular work flow.  They also came up with an acceptable workaround which was to simply uncheck and recheck (i.e., turn off and back on) the georeferenced raster layer in question.  Just one extra step but not too much trouble.

View solution in original post

0 Kudos
3 Replies
DrVSSKiran
Occasional Contributor II

Hi,

For me, it's working fine. I have downloaded your images and I have seen it's falling somewhere in waters as it's just a sample and fake location. 

I used the auto georeference option and fit to display option in georeference tab

later I used to move, scale all other options and place it to some in India forest area. And I hit the save button to save the same image,  and also used save as to saved it to other name.

Please refer to the below screenshot and the attached outputs.

 

DrVSSKiran_0-1623336341509.pngDrVSSKiran_1-1623336393983.png

 

 

0 Kudos
BryanWright
New Contributor III

Thanks for testing it.  A couple of the steps you described are a little different then my workflow but it may be just one of the glitches that is hard to reproduce.  However, I have had a co-worker replicate my problem on a completely different computer and she ran into the same problem.  Thanks again though for trying!

0 Kudos
BryanWright
New Contributor III

Just wanted to follow-up that Esri tech support was able to confirm that the behavior I was encountering was indeed real but it didn't quite rise to the level of a bug since it seemed localized to my particular work flow.  They also came up with an acceptable workaround which was to simply uncheck and recheck (i.e., turn off and back on) the georeferenced raster layer in question.  Just one extra step but not too much trouble.

0 Kudos