After upgrade to 2.7.2 Getting error "You must copy the latest ST_GEOMETRY and dependent libraries to the PostgreSQL software location"

953
4
04-12-2021 05:50 AM
Labels (3)
NileshValwaikar
New Contributor II

I had been using a ArcGIS enterprise 10.8 with PostgreSQL 11 for quite a long time and after a recent update to ArcPro version 2.7.2, i am not able to execute 'Enable Enterprise Geodatabase', 'Create Enterprise Geodatabase', 'Create Spatial Type'.

It gives me the error msg "You must copy the latest ST_GEOMETRY and dependent libraries to the PostgreSQL software location" Although nothing has changed except the Arc Pro update.. I even tried to copy the st_geometry.so file again still the same error..

We are using an ubuntu server for PostgreSQL version 11..

st_geometry.so file is correctly placed in /usr/lib/postgresql/11/lib

When i create a new enterprise geodatabase the database is created along with the same error but its not a enterprise geodatabase.

i have attached the error snapshot.

Note: In my ArcPro installation in Database Support there are no files for Postgresql. I had copied the  st_geometry.so file from my Arc Server instance.

Any help in this regard would be highly appreciated..

Regards,

Nilesh Valwaikar

 

0 Kudos
4 Replies
NileshValwaikar
New Contributor II

Update: I tried from one of the system which was having ArcPro v2.6 and everything is working in that version.

Can anyone let me know how to make this work in v2.7.2 or will i have to revert to v2.6 altogether.

0 Kudos
George_Thompson
Esri Frequent Contributor

What is the sub-version of Postgres 11?

Run this in PGAdmin: "show server_version_num;"

 

--- George T.
0 Kudos
NileshValwaikar
New Contributor II

the sub-version of Postgres 11 is  110009

0 Kudos
Asrujit_SenGupta
MVP Regular Contributor

I feel, you just need to download the correct "st_geometry.so" file from MyEsri relevant for ArcGIS Pro 2.7.

Check the steps I listed in this post: Where can I find ST_Geometry for ArcGIS Pro 2.6 and Postgres v10.10 on Windows

Capture.PNG