Updating/appending data of feature layer does not properly update data in infographics?

1139
12
10-24-2020 04:47 PM
JennyKuan
New Contributor III

Hi,

I created a Web Map with two different infographics displaying the number of votes per political party/candidate. These numbers will need to be updated every ten minutes or so, and I tested out whether "Update Data"/"Append data to layer" would properly update the data inside the infographics. It did something very strange - instead of displaying the proper numbers in the updated table, it multiplied the values! I have appended the table multiple times now but, it keeps multiplying the values - in this instance, multiplying the number of votes. 

I want to be able to click the box "Update existing features" but it is grayed out. I have unique IDs in my Excel sheet but for some reason, it does not show in the Feature Layer table.

Has anyone ever experienced something like this before?

Please see screenshots below for reference.

Thank you,

Jenny

Tags (3)
0 Kudos
12 Replies
Peter_Klingman
Esri Regular Contributor

Hi Jenny Kuan‌,

You will also need to make sure that the field that is unique in your spreadsheet is designated as unique from the Data tab of the hosted feature layer: Manage hosted feature layers—ArcGIS Online Help | Documentation 

If Sync is enabled, update existing features will also be grayed out. You can disable Sync from the Settings tab of your layer. 

Without the update existing features box checked, it makes sense that your chart counts that sort on attributes are increasing each time. This is because each feature in the spreadsheet will be treated as a new feature and added to the count. 

I hope this helps, if you can send me a scrubbed version of your spreadsheet I would be happy to take a look on my end as well. 

Thanks,

-Peter 

0 Kudos
JennyKuan
New Contributor III

Hi Peter,

Thank you for the reply. Despite following those steps, I still was unable to get my data to append properly. I believe it might be due to my limited roles as I am not an admin for my organization on ArcGIS Online.

Thank you for your help though,

Jenny

0 Kudos
Peter_Klingman
Esri Regular Contributor

Hi Jenny,

Thanks for the response; if you own the feature layer it should not matter that you are not an administrator. If the issue were permissions related you would not be able to append at all. I would recommend getting a support case started with Esri Support - let me know and I can get that started for you. 

Best regards,

-Peter 

0 Kudos
DataOfficer
Occasional Contributor III

Hi @Peter_Klingman ,
I am experiencing similar issues as those described by Jenny. I am trying to update (not just append) several hosted feature layers in ArcGIS Online but the update existing features checkbox is greyed out in all the layers I have tested. This is despite following this guidance and ensuring that Sync is disabled, that there is a unique identifier present in both the feature layer and the dataset being used for the updated. I am struggling to work out what is preventing the update existing features option from being accessible. Do you have any suggestions? Furthermore, is there an alternative tool in ArcGIS Pro that allows for update, rather than append?
Many thanks,
Rob

0 Kudos
Peter_Klingman
Esri Regular Contributor

Hi @DataOfficer - can you share a copy of your source data here so I can test on my end? 

A few ideas: 

Even if the values are unique, ArcGIS Online has to know they are unique. In Data > Fields > choose a field > does it show as unique?

PeterKlingman1_0-1607551746820.png

You might be interested in the Update Features request in the Rest API. I've seen this used with a lot of efficacy for smaller, more frequent updates. How many total features are you looking to update and how frequently? 

That said, it would be best to get Append working to update existing features - once I can test out the data you're working with I think I can provide some next steps. 

Thanks,

-Peter 

0 Kudos
DataOfficer
Occasional Contributor III

Hi Peter,

Are you happy for me to add you to a group so you can access the content?

Yes the fields show as unique as you demonstrate. 
Thank you for your suggestion. I have not tried that approach yet and would prefer to get things working through the user interface as there will be other staff who are less specialist needing to perform updates and overwrites to datasets. There are several datasets in question, currently ranging from 10's of features to ~7000. In the longterm however we will be working with some layers containing >500,000 features. Frequency is also variable, but it will generally be fairly sporadic (i.e. once every 1-3 months).

I have just created a very simple point layer in ArcGIS Pro and uploaded it to ArcGIS Online to test the Append/Overwrite functionality. After setting a field as UniqueID, when I upload a slightly edited csv, it does give me the option to Update existing features, but the only field from the ArcGIS Online feature layer that it picks up as unique to match to the csv is the OBJECTID. This is despite another field being set as unique. Furthermore it appears to struggle to match numeric (integer) entries from the csv. If I try running the update using OBJECTID as the unique identifier (as it won't let me select any others), I get the following error: "Object reference not set to an instance of an object.".

I have also tried running the update with a text (string) field as the unique identifier on this test dataset, but this returns the same error as above.

Thanks,
Rob

Peter_Klingman
Esri Regular Contributor

Hi Rob,

Thanks for the details on this - if you would add PeterK_ess to a group that has an export-enabled version of the hosted feature layer and a sample CSV used for updates I will take a look. 

Best,

-Peter

DataOfficer
Occasional Contributor III

Hi Peter,

I have invited you to a group with the feature layer and a sample CSV for updates. I've added details of the issues and steps I have tried in the group description.

Many thanks,
Rob

Peter_Klingman
Esri Regular Contributor

Thanks Rob - about to drop you a private message with my testing results/observations. 

0 Kudos