Trying to add a GeoServer WMS to ArcGIS Online

12669
14
09-12-2011 09:11 AM
AledaFreeman
New Contributor II
Can anyone explain why this doesn't work?  I'm in arcgis.com trying to "Add Layer from web" with 'OGC Web Service (WMS)"

http://giswebservices.massgis.state.ma.us/geoserver/wms

Do I have the correct syntax?

Here is our GetCapabilities:

http://giswebservices.massgis.state.ma.us/geoserver/wms?service=WMS&request=GetCapabilities

We do have a large number of layers and support a large number of projections.

Is there a way to specify one layer to be added?  What would be the correct syntax for that?
Tags (2)
0 Kudos
14 Replies
MikeMinami
Esri Notable Contributor
The getcapabilities file is too big to download and parse in a web browser. Thus, you end up with a timeout in the ArcGIS Online Map Viewer.

You can alternatively use ArcGIS Explorer Online, which runs in a web browser but utilizes the Silverlight plug in to first author your map.


  1. At the top of the application, click the Add Content button

  2. Enter this string in the search box: http://giswebservices.massgis.state.ma.us/geoserver/wms

  3. Click Add and select the layers to add.

  4. Save your map.

  5. Go back to ArcGIS.com and open your map in the map viewer.


thanks,

Mike
0 Kudos
LeonScott
New Contributor II
I was able to add some data from the service in this thread using Explorer.  However, the symbol for the individual layers does not appear anywhere.  Is this a limitation of ArcGIS Online reading from OGC Web Services?


Leon
0 Kudos
BenStewart
New Contributor III
Have you resolved this issue? I haven't been able to add WMS data to an ArcGIS.com map and it is making my life difficult
0 Kudos
SebastienPetit
Occasional Contributor
Have you resolved this issue? I haven't been able to add WMS data to an ArcGIS.com map and it is making my life difficult


Could you post a link to the wms service you want to add?
We are using many WMS to create our maps and do not really have issues with that. (except the legend that is partially fixed now)
0 Kudos
PaulLohr
Regular Contributor

I am interested in using WMS with ArcGIS Online as well. Last I heard, ArcGIS Online does not support pop-ups for WMS.

0 Kudos
MikeMinami
Esri Notable Contributor

This post is now out of date... Popups are supported for WMS. Configure pop-ups—ArcGIS Online Help | ArcGIS 

Note that the ArcGIS Online only supports MIME types of text/plain and text/html in the GetFeatureInfo response.

Paul,

ArcGIS Online does not support popups with WMS. There are no plans to include this ability.

Thanks,

Mike

.

0 Kudos
JacobMaggard
Occasional Contributor II

Mike, is this still the case in 2017?

dlaw-esristaff

0 Kudos
MikeMinami
Esri Notable Contributor

We did implement support for popups in WMS a while back. Here's the appropriate documentation reference.

Configure pop-ups—ArcGIS Online Help | ArcGIS 

Note that the ArcGIS Online only supports MIME types of text/plain and text/html in the GetFeatureInfo response.

Thanks,

Mike

JacobMaggard
Occasional Contributor II

Thanks! 

Any clue why this:    https://walrus.wr.usgs.gov/namss/wms?      version 1.1.1

displays blank popups in AGOL?

Identify is working fine in ArcMap 10.2.2 and 10.4.

0 Kudos