Set transparency from Attribute Values on a layer without numerical values

258
3
05-21-2020 12:27 AM
RaúlJiménez_Ortega
Esri Contributor

I have noticed a strange behaviour, not 100% sure if it is a "bug" so decided to ask here first.

Using this layer I'm trying to set transparency based on an attribute value. I have chosen to define the style based on an String value called "Tipus d'establiments" and using "Unique symbols":

But then, I can not set the transparency based on another attribute:

I guess it is because I don't have any numerical attribute on that layer, but I was expecting to be able to use an Arcade expression to define that numerical value, isn't that possible?.

I have tried a different layer using in this case a different field (but also a String field)

And this time I have noticed that I can set the transparency based on another value:

When I have clicked that option this modal shows up:

In this case, this layer has "Número de componentes" which is an Integer value, and I guess that's the condition the web interface is checking in order to show the "Set from Attribute Value" or not.

Maybe I'm wrong, but if that's the case... should we always display the "Set from Attribute Value" considering that it is always possible to create an Arcade Expression that return a numerical value? In our case we what to check the timetable of a local business and use transparency to show which of those businesses are open at the moment to open the app.

I guess we can do a quick fix adding a numerical value (even if we don't use it), but I just wanted to be sure about what's going on.

 

Best regards,

Raul

P.S: cc: Kelly Gerrow‌, Xander Bakker

0 Kudos
3 Replies
XanderBakker
Esri Esteemed Contributor

Hi Raúl Jiménez Ortega ,

I have seen this behavior also. Not only in ArcGIS Online, but also in ArcGIS Pro. For instance if you want to apply a graduate symbol you need to have a numerical field in your schema even though you would be able to use Arcade to deduce a numerical field from a text or date field. It is a limitation and I see some room for enhancement here.

CC Kory Kramer‌; can you confirm this behavior in ArcGIS Pro?

RaúlJiménez_Ortega
Esri Contributor

Thanks Xander!I didn't know it also happens in ArcGIS Pro. But the good thing is... that there is a way to solve it .

Best regards!,

Raul

KoryKramer
Community Moderator

Hi Xander - I realize this is from ages ago, but these other threads around Arcade and symbology today got me reconnected here...  For this case of wanting to drive graduated symbology from a non-numeric field, it looks like that is now possible.  As I know you're very capable with Arcade😉‌‌, I'm sure it wasn't at the time you posted this, so I have to assume it changed at some point since then.  https://pro.arcgis.com/en/pro-app/2.6/help/mapping/layer-properties/graduated-symbols.htm 


"Graduated symbols can be based on an attribute field in the dataset, or you can write an Arcade expression on which to generate numeric values to symbolize."


Below I'm using graduated colors on the user_id field which is a TEXT field.  Is this what you were looking for?

KoryKramer_0-1611865081386.png

 

0 Kudos