I can't seem to configure my popup for a certain layer

4749
19
Jump to solution
11-02-2016 09:16 AM
JoshWhite
Regular Contributor III

I can't seem to configure a popup in ArcGIS Online.  I have enabled and disabled multiple times and even removed the layer and readded it.  I click on Configure Popup and nothing happens.  What is going on with this?  

Tags (2)
1 Solution

Accepted Solutions
JoshWhite
Regular Contributor III

Ultimately, this had to do with a specific feature class that had somehow become corrupted.  I exported it out to a file geodatabase and then imported it back into my SDE.  Here is the solution write up by Support:

Issue was due to a specific feature class. Able to configure pop-ups after exporting this feature class out to a new feature class and then publishing.

View solution in original post

19 Replies
KatieCullen
Regular Contributor II

Hello,

I have a few questions about the pop-up issue:

- Which browser are you using?

- Does this same behavior happen in other browsers? 

- Is the feature layer shared with the public? If so please provide a link.

- Is this a hosted feature service or an ArcGIS for Server service?

Thanks,

Katie

0 Kudos
JoshWhite
Regular Contributor III

I was using Chrome but I tried Internet Explorer and I am experiencing the same behavior.

http://www.arcgis.com/home/webmap/viewer.html?webmap=5d820fc093f7463d8ae732d282c5167b 

The service is an ArcGIS for Server service.

The problem just cropped up and had not been occurring before.

0 Kudos
KellyGerrow
Esri Frequent Contributor

Hi Josh,

I can enable pop ups on most of the layers in this web map, but not the annotation layer. Which layers are you trying to enable pop ups for?

-Kelly

0 Kudos
JoshWhite
Regular Contributor III

I am working with spaces.  I can enable the popups just fine, I just can't configure them.  For instance, for the link I wanted to change the text to something besides More Info and there are several fields that are duplicates that I would rather just turn off.  Normally these things are simple to fix but only if the configuration dialog comes up.  When I do step 3 for Configure popups at Configure pop-ups—ArcGIS Online Help | ArcGIS 

  1. Browse to the sublayer that contains the feature data you want to configure in a pop-up, click More Options More Options, and click Configure Pop-up.

Nothing happens.  

0 Kudos
by Anonymous User
Not applicable

Hello White,

You can hide or unselect those fields which are not required to show in popup ..
this is the best way and also improve your web page rendering and performance also improve.

0 Kudos
JoshWhite
Regular Contributor III

That's exactly what I am trying to do, but when I hit configure, nothing happens.  

Or maybe I am missing what you are saying.  Are you suggesting I do this in ArcMap before I publish the service?  I can certainly agree with you on that point, but I still need the ability to change the text that shows up for the link.  "More info" doesn't really make sense for what I am wanting the user to do.   

0 Kudos
KatieCullen
Regular Contributor II

Hi Josh,

I would like to get a support case created for this issue. I will send you a direct message.

Katie

0 Kudos
JoshWhite
Regular Contributor III

Thanks, I have started the process

0 Kudos
KatieCullen
Regular Contributor II

Hi Josh White,

If you have time could you post the solution provided from the Support case? This may be helpful for other community members who come across this post.

Thank you,

Katie