Introductory Panel in Nearby Instant App no longer editable

1631
13
Jump to solution
03-06-2023 01:41 PM
Labels (1)
KitsapMaps
New Contributor II

Hi All,

I am having an issue with the ‘Edit introduction panel’ functionality within the Nearby Instant App, no longer allowing me to edit the content within the Introduction Panel. I have tried editing via chrome (including incognito) and edge, but still no change occurred. All other aspect of modification of the Introduction Panel seems to be working fine, such as having it be a splash screen or allowing me to turn it off. As a workaround I tried even just inserting an image of my desired Introduction Panel, but it still did not accept the edit.

Here’s a tiny url link to our publicly available app that is having this issue https://kcowa.us/mywatershed

This has been occurring for a few weeks now. I had hoped that the February ArcGIS Online update would resolve my issue but that doesn’t seem to be the case. @RyanLibed

I’m wondering if there is perhaps some sort of custom css box workaround I can used to make it work. I’ve seen other posts where css was used for the Introduction Panel element was identified as #detailPanel @KellyHutchins

Any suggestions?

Thanks,

-Ryan

1 Solution

Accepted Solutions
KitsapMaps
New Contributor II

My issue has been resolved!

I am able to edit the Introductory Panel again.

Kelly, thank you for suggesting that windows settings change for ‘Show animations in Windows’. My organization a few months ago had toggled this setting OFF. I was able to toggle it back ON and everything worked like a charm.

For Windows 10 users this setting can changed by going to…

Settings->Ease of Access-> (Under the Display section) Simplify and Personalize Windows, and then toggle ‘Show animations in Windows’ back ON.

Also, thanks for letting us know this issue will be addressed in the next release of AGOL.

Here is a list of all the folks and related posts where the resolution was communicated…

@KellyHutchins

@HeatherWidlund

@RyanBohan 

Solved: Re: Nearby Instant App Intro Panel not saving - Esri Community

Solved: Re: Zone Lookup App: Can't make changes to the int... - Page 2 - Esri Community

 

View solution in original post

0 Kudos
13 Replies
KellyHutchins
Esri Frequent Contributor

I see some broken images in the bottom of your apps intro panel when I view it. What happens when you try to edit the app and remove all of the old intro panel then publish then go back in edit and add the new text? 

Does it work if you create a brand new nearby instant app? 

I've tested a few apps and can't reproduce the problem but I'll keep digging into it a bit. The instant apps read all the information that you configure from JSON information stored with the app. You can see the values set in your app here: 

https://kitcowa.maps.arcgis.com/sharing/rest/content/items/d0519a4c8c0e410fbe705bf28330d602/data?f=j...

If you feel comfortable with editing JSON you could try to edit the data using the AGO Assistant tool. Just a warning here that it is possible to break your app using this tool so be careful and perhaps test out the edits on a test app before trying your current application. 

https://assistant.esri-ps.com/

 

 

0 Kudos
KitsapMaps
New Contributor II

Great idea, we are going to take a deeper look that JSON and see what we find out.

0 Kudos
KitsapMaps
New Contributor II

I took a look at it and nothing seemed out of the ordinary.

0 Kudos
KellyHutchins
Esri Frequent Contributor

One more question. After editing what happens if you click outside the edit box and then enable/disable another option?

0 Kudos
KitsapMaps
New Contributor II

Gave that a quick try but it still did not resolve the issue.

0 Kudos
KitsapMaps
New Contributor II

Hi all,

Quick update on this.

Some set of configurations within organization seem to be the barrier.

I was able to talk with someone very helpful from ESRI support on this and we were able to discover that the loss of editing functionality ‘Edit introduction panel’ was only occurring while on my organization's network, on an organization's pc. I was able to edit with no issue off network, on one of my personal devices.

YukoOliver
New Contributor III

Thank you so much!
I was having the same issue with my zone lookup app, and I just tried updating it off my organization network, and it worked!

KimberlyK
New Contributor II

I was having the same issue with my introduction panel while attempting to edit via a VDI setup. Switched to my local desktop to edit through a browser and that was the trick. Thanks for following up on your original question to provide the rest of us with a solution.

0 Kudos
KellyHutchins
Esri Frequent Contributor

Thanks for updating here. We are in the process of troubleshooting this one so the extra info helps us to try and figure out the root cause of the issue.