GeoEvent Version Question

104
2
11-29-2019 05:57 AM
AndySkelton
New Contributor III

My license for GeoEvent 10.6.1 has evidently expired, but I have a license for 10.7.1, so I'm not SOL... Currently, all of my map services for GeoEvent are published to Portal 10.6.1. Am I going to cause issues if I upgrade GeoEvent to 10.7.1, but leave Portal on 10.6.1? The two servers are not federated.

Reply
0 Kudos
2 Replies
Stefan_Jung
Esri Contributor

Hi Andy Skelton‌,

you can upgrade your GeoEvent 10.7.1 and leave your ArcGIS Enterprise on 10.6.1 to use the existing services. You already mentioned the most important part: This only works if they are not federated.

Under Data Stores of your GeoEvent you can register a connection to your ArcGIS Enterprise or ArcGIS Server to access your services.

I am not sure if you will be able to publish new services from GeoEvent 10.7.1 to your 10.6.1 AGE. I would expect that this is going to work but I cannot guarantee it. In general the GeoEvent would publish a hosted feature service, not sure if they there have been some canges from 10.6.1 to 10.7.1.

Best,

Stefan

AndySkelton
New Contributor III

Stefan,

Excellent! I had read in the documentation that if they *were* federated, I'd need to upgrade everything, but I wasn't quite sure what would happen if they weren't federated. Thanks for the clarification!

Reply
0 Kudos