Select to view content in your preferred language

Print widget in EB shows red, green and blue bands

815
8
06-20-2023 08:20 AM
Shubhreet
Occasional Contributor

Hello,

When using the print widget, the legend for my data layers shows red, green and blue bands instead of the actual categories within that data layer. The actual categories are the 5 health regions in Manitoba in green, blue, pink, purple and yellow color. Kindly assist me in getting the legend the right way in the printed map. 

Additionally, is there a way to remove the semi-white coverage over the map extend? 

 

Shubhreet_0-1687274345956.png

 

0 Kudos
8 Replies
ShengdiZhang
Esri Regular Contributor

Hi @Shubhreet ,

I cannot reproduce your issue with my own map and print service. Could share a sample app with me to help investigate the issue?

Thanks,

Shengdi

0 Kudos
Shubhreet
Occasional Contributor

Hello @ShengdiZhang . Thank you getting back to me. I face the same issue every time I try to print in EB. What would be the best way to share the app with you while not making it public? 

0 Kudos
ShengdiZhang
Esri Regular Contributor

Hi, you can share the app and map with a group, and add me to the group. My username is she10946.

0 Kudos
Shubhreet
Occasional Contributor

Thank you for the reply @ShengdiZhang . I have created a group called 'EB Print Widget' with settings as shown in the screenshot below. I am not able to search for you to invite members. 

Shubhreet_0-1695055487007.png

 

0 Kudos
ShengdiZhang
Esri Regular Contributor

Hi, please try the following steps:

1. On the "Who can be in this group" option, select "Any organization's members" 

ShengdiZhang_0-1695112867749.png

2. When inviting new members, enable the option "Search all ArcGIS Online organization members" and disable "Collaboration coordinators only".

ShengdiZhang_1-1695112909829.png

Let me know if you have any other questions.

0 Kudos
Shubhreet
Occasional Contributor

thanks @ShengdiZhang . I have invited to join the group and have shared the web map and app.

0 Kudos
ShengdiZhang
Esri Regular Contributor

Hi @Shubhreet , I can see your map and app now.

After investigating the legend issue, we determined that it was caused by a limitation within the print API in combination with a bug in Experience Builder.

Refer to Print API Reference, when layers utilize effects, the print task will create a client-side image, and the print API does not currently support printing legend items for layers that are rendered as client-side images. You can try printing the same map in the Map Viewer and compare the results. When using the print tool in Map Viewer, you should find that only the "Boundary" layer is included in the generated legend.

In future releases of Experience Builder, any layers rendered as client-side images by the print task due to effects will no longer be sent to the print task. This will make Experience Builder's print behavior consistent with how it currently works in Map Viewer.

For your case, a workaround would be to disable the layer effects.

Hope it helps,

Shengdi

 

 

0 Kudos
Shubhreet
Occasional Contributor

Thank you so much @ShengdiZhang . I removed the effects applied to that layer and now there are no issues in the print. 

0 Kudos