Web adaptor 10.6.1 on ubuntu desktop can’t access any server machines

258
1
03-16-2019 10:27 AM
NicholasReseburg1
New Contributor III

Hello,

my Web adapter currently can’t connect to any server machines (error attached). I tried following the advice here (adapting for ubuntu but still editing the host file) and it didn’t work. Is there an additional steps to get webadaptor to connect to ArcServer? Or alternatively, are there any logs I can look at in web adapter so I can troubleshoot my self?

I have successfully connected to the server and registered it with the web adaptor (VMCKAY as seen in attachment) and have added the server to my Ubuntu hosts file.

I am currently running Web Adapter 10.6.1 in tomcat 5.4.24 with Java 1.8.0_201 on Ubuntu Desktop 16.04.5 as a Virtual Machine using VMWARE workstation 15.0.3 (bridged connection so my server machine is on the same network as my web adapter) running on Ubuntu Server 18.04.2.

My arcserver install is ArcGIS Server for linux 10.6.1 running on Ubuntu Server 16.04.5 s a Virtual Machine using VMWARE workstation 15.0.3 (bridged connection so my server machine is on the same network as my web adapter) running on Ubuntu Server 18.04.2. I am able to ac

I also tried connecting to a windows install of ArcServer 10.61 and got the same thing.

0 Kudos
1 Reply
StevenRamirez
Esri Contributor

Hi Nicholas, 

 Thank you for posting this issue to GeoNet.  I believe there maybe an issue in terms of compatibility between the web adaptor and the underlying tomcat web server. According to the documentation: https://enterprise.arcgis.com/en/system-requirements/10.6/linux/arcgis-web-adaptor-system-requiremen....  Web Adpator at 10.6.X should be used with tomcat version 7.0.82 at a minimum.  I hope this information helps.  

0 Kudos