Select to view content in your preferred language

Survey 123 with ArcGIS Enterprise

501
8
Jump to solution
05-21-2024 08:48 AM
GrantSmith122
New Contributor III

Hi, I am a bit confused on how to access Survey 123 with ArcGIS Enterprise. We have multiple creator licenses that have access to Survey 123. According to this link, I should just be able to log in to the Survey 123 web interface with my Enterprise credentials. When I go to login however, I can't seem to find anywhere to put my organizations URL / credentials. What am I missing here? Do I need to install something on our infrastructure in order to access the platform?

Tags (2)
0 Kudos
1 Solution

Accepted Solutions
MichaelJenkins
Occasional Contributor III

The easy solution is to use survey123.arcgis.com and add the PortalUrl paramter, then there is nothing to install and your AGE authentication will work as expected.  Items you create will be stored in your AGE.   You can then create a link to it and put it in your app menu so you don't have to remeber the URL format.

 

Substitue your AGE URL in this format:

https://survey123.arcgis.com/surveys?portalUrl=https:%2F%2FMyEnterprise.MyOrg.com%2Fportal

GISP

View solution in original post

8 Replies
ZachBodenner
MVP Regular Contributor

You shouldn't need to install anything. Are you using the app icon from the menu in your Portal?

ZachBodenner_0-1716306907180.png

 

0 Kudos
GrantSmith122
New Contributor III

That's where I initially thought it would be, but it doesn't show up in app gallery when I expand it. Do I need to add it in somehow?

GrantSmith122_0-1716307091401.png

 

0 Kudos
ZachBodenner
MVP Regular Contributor

Ah, apparently it's been so long I've forgotten what I did to get it there:

https://doc.arcgis.com/en/survey123/get-started/installsurvey123.htm#ESRI_SECTION1_7D61157E8220443DB...

This section details the location of the file download in MyESRI

0 Kudos
JasminePrater
Occasional Contributor II

Edit: See @MichaelJenkins response below for an easier way to do this without needing to install the app.

You have to go to my.esri.com and download Survey123 from there.  Then you have to install that application on your Portal machine or a dedicated Survey123 machine.  Once installation is complete, you will be able to access the Survey123 webpage connected to your Enterprise.  I am working on this currently and had to change my URL to https://survey123.domain.org:5443/surveys to get it to let me login.  Now I'm  trying to figure out how to change the URL on my Survey123 shortcut. 

Here's a link to a technical document on the installation https://doc.arcgis.com/en/survey123/get-started/installsurvey123.htm#ESRI_SECTION1_7D61157E8220443DB...

Since I had issues finding the app download, I'll give you the location.  The Survey123 application can be found by going into Enterprise 11.2 on my.esri.com, then switching the versions to what you are using.  See pic below.

JasminePrater_1-1716308424404.png

You then have to scroll down to the Apps category and it's the last item.

JasminePrater_2-1716308506887.png

Hope that helps!

 

0 Kudos
MichaelJenkins
Occasional Contributor III

The easy solution is to use survey123.arcgis.com and add the PortalUrl paramter, then there is nothing to install and your AGE authentication will work as expected.  Items you create will be stored in your AGE.   You can then create a link to it and put it in your app menu so you don't have to remeber the URL format.

 

Substitue your AGE URL in this format:

https://survey123.arcgis.com/surveys?portalUrl=https:%2F%2FMyEnterprise.MyOrg.com%2Fportal

GISP
JasminePrater
Occasional Contributor II

When I tried to use this URL, the page after failed to load.  For the "MyEnterprise" part of the URL, what should be used?  I tried portal, since that is the name of our Portal machine.  Perhaps that is wrong and why my page didn't load.

Edit: I just tried it using my other server name in place of the "MyEnterprise" and that worked in survey.arcgis.com.  Thanks for that tip!

GrantSmith122
New Contributor III

Hey Jasmine, try your portal url. I put in portalUrl=https://myportal.gov/portal and I was able to get in with no problem. There's a banner across the top that displays your Portal URL as well so you can confirm you're in the right place.

 

Thanks for this Michael!! Working great now

MichaelJenkins
Occasional Contributor III

Use  the URL to your Portal home page.  https://MyEnterprise.MyOrg.com/portal for example

GISP
0 Kudos