SSO experience in ArcGIS Server (stand alone, not federated to an ArcGIS Portal)

1033
4
Jump to solution
01-22-2021 09:24 AM
BanchanaPandey
New Contributor III

Is there any documentation on how to configure azure ad sso on a stand alone arcgis server? Everything that comes up is just for ArcGIS Enterprise which has Portal in it. 

Is this even a possibility in a non-federated, stand alone arcgis server?

Our arcgis server is installed in a windows based machine with web adaptor and web tier authentication.

Right now, we are getting prompted for credentials, even after we provide our credentials through the Azure AD SSO which uses a SAML protocol. The credentials are not being passed through to the arcgis server. Almost feels like web adaptor is not getting the credential information from IIS and is not able to supply that to arcgis server.

Thanks!

0 Kudos
1 Solution

Accepted Solutions
DEWright_CA
Occasional Contributor III

ArcGIS Server to authenticate using AD requires a psuedo-LDAP interface; the ability to handle SAML/XML isn't available at the AGS layer; only in Federated Portal to ArcGIS Server.

View solution in original post

4 Replies
ZianChoy
Occasional Contributor
0 Kudos
DEWright_CA
Occasional Contributor III

Then llikely will need to go through here...

LDAP authentication with Azure Active Directory 

0 Kudos
BanchanaPandey
New Contributor III

We are not using LDAP. We are using SAML.

0 Kudos
DEWright_CA
Occasional Contributor III

ArcGIS Server to authenticate using AD requires a psuedo-LDAP interface; the ability to handle SAML/XML isn't available at the AGS layer; only in Federated Portal to ArcGIS Server.