Services are not showing in ArcGIS Server Manager

2384
6
Jump to solution
12-25-2018 09:02 PM
eyadghatasheh
New Contributor III

Hi,

I have hundreds of map services and feature services published to my ArcGIS Server and classified inside different folders. accidentally, no service at the root level or inside folders appears. folders still there and the data is available at C:\arcgisserver\directories\arcgisoutput

all applications that are consuming these services stop working. what could be the cause of this?

Tags (1)
0 Kudos
1 Solution

Accepted Solutions
ZahinaKhan
New Contributor III

Hello Eyad,

According to the screen shot, your ArcGIS Server has only the "Image Server" license role. You will need the "ArcGIS GIS Server" license role for the services.

Go to my.esri.com > my organization > licensing > view authorization > ArcGIS GIS Server > version 10.6-10.6.1 > details > Copy the ECP number.

Go to your ArcGIS Server machine > launch "software authorization for ArcGIS Server" from the windows menu >

          1) "I have installed my software and need to authorize it"

          2) If you have internet on the machine select "Authorize with Esri now using the Internet"

          3) Fill out your and your organization's information in the next two windows

          4) Enter the GIS Server license ECPcode in the blank space for "ArcGIS Server"

          5) Finish authorization.

Check in https://arcgisservermanager > site > software authorization > if the GIS Server role is now showing up and all your services are visible.

If not, please restart the ArcGIS Server service from services.msc > ArcGIS Server > restart.

View solution in original post

6 Replies
ZahinaKhan
New Contributor III

Hello Eyad.

Did you recently updated the ArcGIS Server license? 

I have seen issues where the license level has changed and the services won't show up. Or if the license has expired. 

You can check the authorized licenses by going to https://ArcGIS Server Manager > site > software authorization. 

If you can attach a screenshot from the software authorization windows, I can have a look at it. 

Regards, 

Zahina

eyadghatasheh
New Contributor III

Hello Zahina,,,

this exactly what happened. here is the snapshot.

0 Kudos
ZahinaKhan
New Contributor III

Hello Eyad,

According to the screen shot, your ArcGIS Server has only the "Image Server" license role. You will need the "ArcGIS GIS Server" license role for the services.

Go to my.esri.com > my organization > licensing > view authorization > ArcGIS GIS Server > version 10.6-10.6.1 > details > Copy the ECP number.

Go to your ArcGIS Server machine > launch "software authorization for ArcGIS Server" from the windows menu >

          1) "I have installed my software and need to authorize it"

          2) If you have internet on the machine select "Authorize with Esri now using the Internet"

          3) Fill out your and your organization's information in the next two windows

          4) Enter the GIS Server license ECPcode in the blank space for "ArcGIS Server"

          5) Finish authorization.

Check in https://arcgisservermanager > site > software authorization > if the GIS Server role is now showing up and all your services are visible.

If not, please restart the ArcGIS Server service from services.msc > ArcGIS Server > restart.

eyadghatasheh
New Contributor III

Thanks a million Zahina, that was great.

0 Kudos
JoshuaBixby
MVP Esteemed Contributor

If Zahina's response addressed your issue, please mark it correct to close your question out.

0 Kudos
jamiehollingsworth
New Contributor II

So i just ran into this and am wondering if you can clarify that if image server is the only role listed in manager that my mapservices will not longer be listed?  

there should be several roles listed?

i did reauthorize my server ECP by still only see image server as the only role.

0 Kudos