Server Manager and JSON Representation of a Service do not match

484
1
Jump to solution
10-13-2021 06:08 AM
TigerWoulds
Occasional Contributor III

Running ArcGIS Enterprise 1081. I have a python script that loops through a folder in Server Manager and updates the Capabilities for a Feature Server to 'Extract, Delete, Update'. The script runs successfully and my REST API POST request works fine.

My issue is that Server Manager only shows Extract as a capability while the JSON representation shows the update with all three capabilities. These appear to be out of sync...

Server Manager

TigerWoulds_0-1634129970776.png

I am finding the JSON representation from the Server Admin directory.

https://test.com/arcgis/admin/services/testFolder/TestService.MapServer?f=json

TigerWoulds_1-1634130293628.png

 

Has anyone seen this before? Any ideas and what I need to do to fix this?

0 Kudos
1 Solution

Accepted Solutions
TigerWoulds
Occasional Contributor III

Found the solution, for anyone who may run into this. It was a bug in my code. 

The string that I'm passing for the Capabilities cannot contain spaces. 

So, rather than 'Extract, Delete, Update' it needs to be 'Extract,Delete,Update'

Long story short is that my JSON I was trying to post was formatted incorrectly. So the the GIS Server was only taking the first capability (in my case, Extract).

View solution in original post

0 Kudos
1 Reply
TigerWoulds
Occasional Contributor III

Found the solution, for anyone who may run into this. It was a bug in my code. 

The string that I'm passing for the Capabilities cannot contain spaces. 

So, rather than 'Extract, Delete, Update' it needs to be 'Extract,Delete,Update'

Long story short is that my JSON I was trying to post was formatted incorrectly. So the the GIS Server was only taking the first capability (in my case, Extract).

0 Kudos