Publishing mxd that contains a mosaic dataset ends up with the error “Packaging succeeded but publishing failed”

634
4
06-20-2017 01:00 AM
AlaaFlaifel
Occasional Contributor

"Despite the fact that publishing mxd that contains a feature class works successfully, Publishing mxd that contains a mosaic dataset ends up with the error “Packaging succeeded but publishing failed”"

I’m trying to publish mxd that contains a mosaic dataset but it ends up with the error “Packaging succeeded but publishing failed”, Although publishing success when using mxd that contains a feature class.

Please note that the data and the mxd are stored on a server different from the one that has the ArcGIS Server and the connection is made via shared folder.

What might be the issue here?

4 Replies
JayantaPoddar
MVP Esteemed Contributor
0 Kudos
JakeSkinner
Esri Esteemed Contributor

Hi Alaa,

Do you have the ArcGIS Image Server extension?  This is required in order to publish a mosaic dataset to ArcGIS Server.

JamalNUMAN
Esteemed Contributor

Hi Jake,

 

Sure, we have a licensed ArcGIS Image Server extension. However, we are struggling with this frustrating error in all releases of ArcGIS with no root solution for it.

----------------------------------------
Jamal Numan
Geomolg Geoportal for Spatial Information
Ramallah, West Bank, Palestine
JonathanQuinn
Esri Frequent Contributor

When you see "publishing failed", that means that the SD file that has been packaged, (indicated by "packaging succeeded"), and has been moved to the Server for unpacking and publishing.  Since the SD file has been moved to the Server, you'll need to look at the Server logs to determine why publishing failed.  Setting the logs to DEBUG should give you some useful information if VERBOSE through SEVERE logs don't provide much.