Publishing Custom Print Service from Pro to Enterprise/Server

467
1
04-29-2021 02:28 PM
Arne_Gelfert
Regular Contributor

In the process of migrating from 10.6 Enterprise to 10.8 and having to republish some service. Now I'm getting a weird error from Print widget.

So I stumbled across this and my reading Pro 2.5 cannot publish print services to AGS 10.8? Correct??

 

If you're publishing a geoprocessing service, the ArcGIS Desktop and ArcGIS Server versions must match.

 

(from: https://enterprise.arcgis.com/en/server/latest/get-started/windows/compatibility-of-arcgis-for-serve...)

0 Kudos
1 Reply
Arne_Gelfert
Regular Contributor

Sounds like 10.8 === 2.6.


For example, if you create an enterprise geodatabase from ArcMap 10.6.1, the geodatabase version is 10.6.1. If you subsequently upgrade the same geodatabase using ArcGIS Pro 2.6, the geodatabase version is 10.8.1.2.6. (https://pro.arcgis.com/en/pro-app/latest/help/data/geodatabases/overview/client-geodatabase-compatib...)

 Which means upgrading to Pro 2.6 (probably about time anyways). Would be nice, ESRI, if this were a little easier to decipher and not tucked away on the geodatabase pages!

0 Kudos