Publishing a shapefile to portal

1142
5
03-27-2019 08:38 AM
AndrewDolch2
New Contributor III

We are trying to create a ublish a  hosted layer from a shapefile that we're importing from a ZIP folder.  When we go to import it we keep getting an error,   I have gone in checked the error logs and get the following error ERROR 001506: Failed to download the data for the portal item. Failed to execute (Publish Portal Service). Failed. Failed to execute (Publish Portal Service).   I have also published the shapefile directly and then create the feature and it didn't work .  I also tried publishing from ArcGIS Pro and got the same error  checked the ESRI documentation and it was I got 

Portal's hosted server cannot access the data referenced by the item that will be published as a service.

Solution

Ensure that portal's hosted server has permissions to access the data referenced by the item that you want to publish. See Making your data accessible to ArcGIS Server for more information..    

Do you know what is going on?   Is it a configuration issue?  Is there something I'm missing or is it one of the many quirks that makes Portal burdensome

0 Kudos
5 Replies
JonathanQuinn
Esri Frequent Contributor

Can you describe you environment a bit? Are Portal and Server on the same machine, or different machines? Is it HA? If it's not HA and they're on different machines, can you reach https://portal.domain.com:7443/arcgis/sharing/rest on the Server machine?

0 Kudos
AndrewDolch2
New Contributor III

I am trying this on our staging environment where all the portal and server on the same machine.   I have to put it on our production too where we are running two servers on two separate machines than the portal.   What is HA if you don't mind me asking   I have tried what you said above and  and am able to reach my security config.   I went into the server config and even added the arcgis/sharing/rest to the private URL.   It didn't work  I now get this error Publish exception 'Server machine 'https://internalportalname.domain.gov:443/arcgis/sharing/rest/sharing/rest/community/self' returned an error. 'Invalid URL'' .  Do you have any further suggestions.

0 Kudos
JonathanQuinn
Esri Frequent Contributor

HA means high availability which requires specific settings and configurations.

The privatePortalURL should be https://internalportalname.domain.gov:7443/arcgis, there shouldn't be a reason to update it. Was that what it was set to previously? At a high level, the publishing process goes as follows:

1) The item to publish is uploaded to Portal

2) Server will download the item via a URL constructed from the privatePortalURL, https://internalportalname.domain.gov:7443/arcgis

3) The Server will extract the item, (for example, the shapefile or SD file) and publish it

It sounds like it's failing at step 2. Did you do anything to modify the certificate used for 7443, or is this all configured out of the box without any customizations?

0 Kudos
AndrewDolch2
New Contributor III

Jonathan,

To answer your questions.

1.  The cert is straight out of the box because I had to do a restore on my Portal for ArcGIS because of an unrelated issue. 

2.   I have not made any changes to config especially the PrivatePortalURL

{
"portalUrl": "https://gisdev.transportation.wv.gov/portal",
"privatePortalUrl": ", https://internalportalname.domain.gov:7443/arcgis",

3.  I have tried to publish something again today after I had repaired portal and was getting the same Error. 

4.  I was able to go to the site but when checked the self signed cert, it was saying I was not logged it even though I am.    Would that have anything to do with it?   

5.  Is there any work around at step two that you know of to fix the problem  I have had a chance to read your other post and followed that to a tee and still had the same result.   Please let me know if you can figure out a solution.

Thanks.

Andrew

0 Kudos
AndresFelipeRiapira
New Contributor

Hello Andrew. Did you find any solution to 001506 error? I got the same, even with CSV files.

I have Portal and Server on the same machine
Thanks.

0 Kudos