Portal for ArcGIS - Enterprise Group ?

2088
4
Jump to solution
01-22-2018 08:34 AM
MayurDodiya
Occasional Contributor

Hi,

I configured LDAP in user store configuration and group store configuration portal admin directory.

I can see the list of AD users and groups, search users and groups from AD.

Now, I want to use existing enterprise AD group e.g. "Engineering GIS" as portal group than, I have certain ArcGIS Server map services that I want to share with that specific group "Engineering GIS".

Similarly, I have another existing enterprise AD group e.g. "Roads GIS" want to use as portal group than, I have certain Web apps that I want to share with that specific group "Roads GIS".

I logging  as Portal administrator I go to My organization > Add members > Add members based on existing enterprise users > I see the option add from group, here I can search enterprise group and assign role to users but, don't see the options to create and use as Portal Group or link to existing portal group.

How can I link existing enterprise group with portal group ? How do I add enterprise group to portal group ? 

Also, I wan to design home page based on different types user e.g user1 is member of group1 so can see the group1 content on home page, similarly, user2 is member of group2 so can see the group2 content on home page?

Any ideas or alternative way to share map services and apps to the specific enterprise group ? Home page based on different user type ?

I am using Portal for ArcGIS 10.5 federated with ArcGIS Server. 

Thanks,

1 Solution

Accepted Solutions
PhilipMcNeilly
Esri Contributor

Hi Mayur,

You can create groups that are linked in enterprise groups.  The workflow is the same as creating a 'built in' Portal group, but you will chose "From an Enterprise Group" when creating the group.

See step 7 below.

Create groups—Portal for ArcGIS (10.5.x) | ArcGIS Enterprise 

View solution in original post

4 Replies
PhilipMcNeilly
Esri Contributor

Hi Mayur,

You can create groups that are linked in enterprise groups.  The workflow is the same as creating a 'built in' Portal group, but you will chose "From an Enterprise Group" when creating the group.

See step 7 below.

Create groups—Portal for ArcGIS (10.5.x) | ArcGIS Enterprise 

View solution in original post

MayurDodiya
Occasional Contributor

Hi Philip,

Yes, I did same. I go to Groups > Create Groups > and than users from enterprise group, I searched group from enterprise group, select group and save. Now it is showing your existing member of portal that are also member of this enterprise group.

Now, That I have created group and users from enterprise group, I shared my items to the group I created, and when users that are group members try to open it is redirecting to sign in page. Even, if i share public everyone and access items it is redirecting to Sign in page. 

I have to add users as portal member from the enterprise group I created ? How can I share items with enterprise group ? What does the enterprise group and link to enterprise group mean in Portal ? 

yockee
by
New Contributor II

Hi @Mayur Dodiya,

Can you share the configuration that you typed ? Mine looks like this :

 

  "type": "LDAP",

  "properties": {

    "userPassword": "8Hh9Esm7Zb0uqQVWSud...VW4tq0IL5x87bDpMIXqZYOqa41m0oOi5j4gXptNkIsD6d",

    "sAMAccountName": "uid=myname,OU=xx,OU=User Accounts,OU=ou1,OU=ou2,DC=ppp,DC=com",

    "caseSensitive": "false",

    "userEmailAttribute": "mail",

    "usernameAttribute": "cn",

    "userFullnameAttribute": "cn",

    "ldapURLForUsers": "ldap://ldap-address/OU=User Accounts,OU=ou1,OU=ou2,DC=ppp,DC=com",

    "isPasswordEncrypted": "true"

  }

}

 

It says "successful" during the Update Identity Store, but when i try to list the user in Get Enterprise User, it gives out error : "Portal Administrator Directory

[LDAP: error code 1 - 000004DC: LdapErr: DSID-0C0907C2, comment: In order to perform this operation a successful bind must be completed on the connection., data 0, v2580]

0 Kudos
MayurDodiya
Occasional Contributor

Hi @yoc kee,

Below is my configuration in Portal Admin directory here : Home  >  Security  >  Config  >  Update Identity Store

{
"type": "WINDOWS",
"properties": {
"userPassword": "password",
"caseSensitive": "false",
"userEmailAttribute": "mail",
"user": "domainname\\username",
"userFullnameAttribute": "cn",
"isPasswordEncrypted": "true"
}
}

I followed this steps in this video : Configuring Portal for ArcGIS with Integrated Windows Authentication - YouTube and it worked for me.

Thanks,

Dodiya Mayur

0 Kudos