Password authentication failed when updating the datastore from 10.7.1 to 10.8.1

1539
3
Jump to solution
11-16-2020 09:25 AM
lvargas
New Contributor III

Hello,

The environment is ArcGIS Enterprise 10.7.1 federated and distributed in 3 servers running Windows Server  (Portal + IIS, ArcGIS GIS Server and DataStore), is working normally and are virtualized servers in VMware.

The upgrade of Portal, WebAdaptors and ArcGIS GIS Server to version 10.8.1 is done correctly; the remaining element to update is the DataStore (Relational).

The wizard is executed ends fins and we proceeds to finalize the update process (imagen10.png).

But we have an issue indicates that the user adm_i2dll (administrator of the DataStore that is created automatically) does not have a password (imagen12.png)

We have tried in differents web browsers as well as from the terminal.

Error encountered: Machine 'https://localhost:2443/arcgis/datastoreadmin' returned an error. 'Attempt to configure data store failed.Caused by: No valid connection to ArcGIS Data Store configuration store established.
Caused by: FATAL: the password authentication failed for the user «adm_i2dll» (pgjdbc: autodetected server-encoding to be ISO-8859-1, if the message is not readable, please check database logs and/or host, port, dbname, user, password, pg_hba.conf)'

Log:
2020-10-23 15:41:53 CST: [5036]: [1-1] FATAL: Password authentication failed for user "adm_i2dll".
2020-10-23 15:41:53 CST: [5036]: [2-1] DETAILS: User "adm_i2dll" is not assigned a password.

Have you seen this inconvenience? They have known how to solve it.

We have a support case but no progress has been made.

Regards.

0 Kudos
1 Solution

Accepted Solutions
lvargas
New Contributor III

Hello,

It is not known why the datastore administrator loses the password, but this happens when trying to upgrade it.

Having the Data Store in 10.7.1 we make a recent backup (relational), then upgrade from 10.7.1 to 10.8.1, stop the service, rename the DataStore folder (c:\arcgisdatastore to arcgisdatastore_old) use the tool to load the backup (relational created in arcgisdatastore_old folder) and wait the process to finish. When the DataStore backup is loaded is already in 10.8.1.

ArcGIS GIS Server and ArcGIS Data Store services are restarted, and the Data Store Relational works normally.

I hope the information is useful.

View solution in original post

3 Replies
DavidColey
Frequent Contributor

Hello - it looks to me like you have an account issue.  You should have seen this from step 5 in the help:

https://enterprise.arcgis.com/en/portal/latest/administer/windows/upgrade-data-store.htm#GUID-FBB3BF...

"The account used by your existing installation is prepopulated in the ArcGIS Data Store input box. Provide the password for the account. Typically, this is the password you defined when installing the software . . . . "  

 

This should be the same domain account that is running server.  If the datastore server can't get to that domain account, it looks like it's defaulting to the datastore internal local account.

 

 

 

0 Kudos
lvargas
New Contributor III

Hello David,

Thank you for your response.

In this case it is not the service account, the AGE services use an AD account created for that purpose; we can start the final update process once the wizard is finished (1.png and 2.png).

The account indicated in the message (3.png) is the account of the relational data store administrator. This is one of the three accounts created and the datastore automatically generates a password for it (adm_abc, dsrepuser and sde are the accounts) (4.png).

Before making the final update using the web browser or the console, we can see the users  information. This ones are only used by the DataStore and ArcGIS GIS Server internally.

Regards.

0 Kudos
lvargas
New Contributor III

Hello,

It is not known why the datastore administrator loses the password, but this happens when trying to upgrade it.

Having the Data Store in 10.7.1 we make a recent backup (relational), then upgrade from 10.7.1 to 10.8.1, stop the service, rename the DataStore folder (c:\arcgisdatastore to arcgisdatastore_old) use the tool to load the backup (relational created in arcgisdatastore_old folder) and wait the process to finish. When the DataStore backup is loaded is already in 10.8.1.

ArcGIS GIS Server and ArcGIS Data Store services are restarted, and the Data Store Relational works normally.

I hope the information is useful.

View solution in original post