outStatistics return 'unable to complete operation'

3553
8
Jump to solution
11-05-2015 01:37 PM
JadeFreeman
Occasional Contributor III

We are setting up a new ArcGIS Server 10.3.1 instance and are experimenting with the statistical queries.  However, any time we use the 'outStatistics' parameter, we get a 'unable to complete operation' error.  Digging thru the server logs all we can see is a 'general geodatabase' error message.

Our data is in Oracle Spatial 11gR2.

Has anyone else had issues with statistical queries?  It's a bummer as many of the widgets in Operations Dashboard rely on these which precludes their use for us.

Here is an example of a typical outStatistics request:

[

  {

    "statisticType": "sum",

    "onStatisticField": "SHAPE.LEN",

    "outStatisticFieldName": "Length"

  }

]

Thanks!

0 Kudos
1 Solution

Accepted Solutions
MarkCederholm
Regular Contributor II

Esri reproduced the problem, and submitted a software defect:

BUG-000092566 : Query task with Output Statistics fails on an Oracle layer/table in a map service published on ArcGIS Server if the data is in geometry other than Esri ST_Geometry data type.

View solution in original post

8 Replies
MarkCederholm
Regular Contributor II

I also have Oracle 11gR2; I'm seeing the issue in both 10.3 and 10.31, and my log shows the following error:

Geodatabase error: Query does not have spatial column.

I'm still looking around for REST or JavaScript examples in case I have something badly formed in the query.

JadeFreeman
Occasional Contributor III

Hi Mark,

Good to know we are not alone!  At this point I have not found any resolution to the issue and have had to abandon the use of the statistical queries which really limits what you can do with Operations Dashboard unfortunately.  Many of the widgets rely on these service calls to get the data.

I've tested against geodb feature classes, geodb tables, query layers (which are supposed to be supported in 10.3.1) and have not been able to identify any pattern.

Jade

0 Kudos
MarkCederholm
Regular Contributor II

FYI, I'm working with Esri tech support on this.  For some odd reason, it appears that the statistics query is only working on feature classes with ST_GEOMETRY storage: all of our other feature classes are Esri LOB storage, and the statistics query isn't working with them.  I'll let you know how it turns out.

0 Kudos
MarkCederholm
Regular Contributor II

Esri reproduced the problem, and submitted a software defect:

BUG-000092566 : Query task with Output Statistics fails on an Oracle layer/table in a map service published on ArcGIS Server if the data is in geometry other than Esri ST_Geometry data type.

JadeFreeman
Occasional Contributor III

Thanks for the update!  I wonder how long it will take to get this fixed?  This is a pretty big deal for us...

0 Kudos
MarkCederholm
Regular Contributor II

I migrated my two reporting classes to ST_GEOMETRY, and now the statistics work fine.  They're regenerated each night by a geoprocessing script, and are not edited by other users, so I had no problem with doing that.  If you're as squeamish as I am about migrating everything, you might consider creating a one-way replica and publishing your web services off of that.  I've thought about doing that myself, but never got around to it.

0 Kudos
JadeFreeman
Occasional Contributor III

I was thinking about this last night and wondered if the same bug applies to statistical queries on tables?  I have the same problems with tables that don't have geometry.  Same with query layers although I could see this being related to the bug if they use Oracle's SDO_GEOMETRY.

0 Kudos
JadeFreeman
Occasional Contributor III

I can confirm that this same bug replies to tables as well.  In other words query layers that don't have a shape field.  Hopefully Esri will do something about this soon!!!!

In the meantime, they should update operations dashboard to not use the statistical queries!

0 Kudos