Notebook server on linux not start container

744
5
Jump to solution
06-08-2021 05:38 AM
Oiligriv
Occasional Contributor

Hello
I installed Arcgis Notebook Server on Red Hat Enterprise with the docker component.

The whole setup seems to work just fine.
but when I cast a Cantainer I get an error

 

RFIAPPLBS01LE.RFISERVIZI.CORP - Failed to create and start a Docker Container. 'Failed to create and start a Docker Container. 'Request error: POST unix://localhost:80/containers/5fb406e300e02d5bdca8aedd54de893990ec73853cf64a687c23d6648a9724b0/start: 500, body: {"message":"driver failed programming external connectivity on endpoint f4b8f3d4bbfc457881bbff66102886db (75031b2d807bb82c6fdf5d3fe1fea9776efec5341382a702dde6805355108563): Error starting userland proxy: listen tcp6 [::]:30001: socket: address family not supported by protocol"}'.'.

 

Investigating I found that on the server, IPV6 is disabled.
which solution is the best?
1) enable ipv6 on the server?
2) disable ipv6 on docker or container?

Thanks

0 Kudos
1 Solution

Accepted Solutions
JonEmch
Esri Regular Contributor

Hey there,

   Did some research on this, and found that running * Activate ipv6 in / etc / grub * update-grub * reboot may resolve thi sissue.

Keep on keeping on!

View solution in original post

0 Kudos
5 Replies
JonEmch
Esri Regular Contributor

Hey there,

   Did some research on this, and found that running * Activate ipv6 in / etc / grub * update-grub * reboot may resolve thi sissue.

Keep on keeping on!
0 Kudos
Oiligriv
Occasional Contributor

is it possible to disable IPV6 from docker?

0 Kudos
JonEmch
Esri Regular Contributor

You can according to https://mailcow.github.io/mailcow-dockerized-docs/firststeps-disable_ipv6/, but im not sure if that is the best move.

Keep on keeping on!
0 Kudos
Oiligriv
Occasional Contributor

Hi JonEmch
we have enabled IPV6 on the Loopback network card.

ArcGIS Notebook server is now able to successfully initialize Containers

Thanks

JonEmch
Esri Regular Contributor

Great to hear! Glad I could help.

Keep on keeping on!
0 Kudos