Select to view content in your preferred language

I cant to Register Postgres database

467
5
06-21-2023 02:22 AM
AhmedTarek123
New Contributor II

Hello 

I user ArcGIS Enterprise Version 10.8.1 and i have issue to register  Postgres database but I can register Sql Database  and Get these Error 
(The connection property set was missing a required property or the property value was unrecognized. The connection property set was missing a required property or the property value was unrecognized)

0 Kudos
5 Replies
George_Thompson
Esri Frequent Contributor

What is the version of Postgres that you are using?

Is the database a geodatabase? If so, what is the version of the geodatabase?

Do you have the pg_hba.conf configured to allow the server machine to connect?

Are you able to connect via PGAdmin from the server machine to the PostgreSQL database?

 

--- George T.
0 Kudos
AhmedTarek123
New Contributor II

Postgres Version is  PostgreSQL_12.2

and the pg_hba.conf is configured as attached 

AhmedTarek123_0-1687351216430.png

and i can connect via PG admin and connect to database

0 Kudos
George_Thompson
Esri Frequent Contributor

Ok, is there Pro on the Server machine that can connect to the PG database?

Is it an enterprise geodatabase or just a PG database?

Just to be sure, this PostgreSQL DB is NOT the one being used by datastore?

--- George T.
0 Kudos
AhmedTarek123
New Contributor II

thanks Pro 

the database is created by arcgis pro 

0 Kudos
George_Thompson
Esri Frequent Contributor

Ok, thanks for that. You may need to work with technical support on this for a deeper dive into it.

--- George T.
0 Kudos