How to set up two Web Adaptors on one machine (for AG Server and Portal)

6564
10
Jump to solution
09-25-2014 08:18 AM
TomaszW_
New Contributor II

Hi,

I want to set up two different Web Adaptors on one machine - one for ArcGIS Server and one for Portal for ArcGIS.

I work with version 10.2.2 on Windows Server 2008 R2

I installed first Web Adaptor and configured it's name for 'waportal'. Than configured it with Portal.

Then I tried to install Web Adaptor again - but I had no post-install set-up of Web Adaptor name. I had only options to Modify, Repair, Uninstall - non of those lead to name set-up.

I know that it's possible to have two different names - this is the help:

ArcGIS Web Adaptor (IIS) installation guide

Do you have any ideas how to set it up?

Tags (1)
1 Solution

Accepted Solutions
KhairulAmri1
New Contributor II

Hi Tomasz,

I got same problem in Windows Server 2008 R2, however its working on windows 7, we can install webadaptor 2 times using same installer. WebAdaptor is web application act like reverse proxy, so the workaround for this issue is duplicate your existing webadaptor as second webadaptor.

here is the detail steps: (i assumed you used IIS and installed webadaptor on inepub/wwwroot/)

1. wa already installed, and you name it 'waportal' > don't register anything in here (portal or arcgis server)

2. go to c:/inetpub/wwwroot -> copy 'waportal' and paste on the same place c:/inetpub/wwroot/

    by default second wa name is 'waportal copy'. rename it, for example 'waserver'

3. you have to convert 'waserver' as application. go to IIS Manager > in the left side expand Default Website > right click in waserver, choose convert to application

5. you have 2 wa right now. the first is waportal and the second is waserver.

a. register your portal on your waportal

go to http://yourhost/waportal/webadaptor/ > select portal for arcgis then follow the instruction

b. register your arcgis server on your waserver

go to http://yourhost/waserver/webadaptor/ > select arcgis for server then follow the instruction.

it's work for me,

Amri

View solution in original post

10 Replies
BrendanDwyer
Occasional Contributor

Doesn't the web adaptor give you the option of a portal and a server in the post-install?  Why do you want two installs of the web adaptor on one machine?

0 Kudos
TomaszW_
New Contributor II

Yes, I have option to register portal and server but I suppose that the same Web Adaptor name doesn't allow me to federate server with Portal.

0 Kudos
StevenGraf1
Regular Contributor

You might try renaming the .exe file and running it a 2nd time.

0 Kudos
TomaszW_
New Contributor II

I'll try, but I expect that installer will detect installed Web Adaptor.

EDIT: In fact the installer behavior is the same - only options for Modify, Repair and Uninstall.

0 Kudos
DavidColey
Frequent Contributor

As far as I know ESRI doesn't allow you to register both.  You can either install and register Portal for your Organization account, or you can register AGOL, so it may be a moot point in trying to set up both, unless you have two organizational accounts.

0 Kudos
TomaszW_
New Contributor II

I asked about ArcGIS for Server and Portal for ArcGIS on two separate Web Adaptor names on one server. Not about AGOL:)

0 Kudos
KhairulAmri1
New Contributor II

Hi Tomasz,

I got same problem in Windows Server 2008 R2, however its working on windows 7, we can install webadaptor 2 times using same installer. WebAdaptor is web application act like reverse proxy, so the workaround for this issue is duplicate your existing webadaptor as second webadaptor.

here is the detail steps: (i assumed you used IIS and installed webadaptor on inepub/wwwroot/)

1. wa already installed, and you name it 'waportal' > don't register anything in here (portal or arcgis server)

2. go to c:/inetpub/wwwroot -> copy 'waportal' and paste on the same place c:/inetpub/wwroot/

    by default second wa name is 'waportal copy'. rename it, for example 'waserver'

3. you have to convert 'waserver' as application. go to IIS Manager > in the left side expand Default Website > right click in waserver, choose convert to application

5. you have 2 wa right now. the first is waportal and the second is waserver.

a. register your portal on your waportal

go to http://yourhost/waportal/webadaptor/ > select portal for arcgis then follow the instruction

b. register your arcgis server on your waserver

go to http://yourhost/waserver/webadaptor/ > select arcgis for server then follow the instruction.

it's work for me,

Amri

View solution in original post

TomaszW_
New Contributor II

Amri,

Great workaround!

Some additions:

In step 3, I had to chose: ArcGISWebAdaptorAppPool as application pool.

Moreover, I had to copy permissions from waportal\WebAdaptor.config to waserver\WebAdaptor.config (there's additional account 'ArcGISWebAdaptorAppPool' which I couldn't find in system. This account must have permissions to this file to save configuration)

VinodBorkar1
New Contributor

Thanks a lot.

this workaround is very much useful.

0 Kudos