How do I disable max feature limit?

745
7
Jump to solution
03-11-2019 08:46 AM
LR
by
Regular Contributor

I'm trying to load a feature service in a 3D Scene, but get the following error: Feature service exceeds max feature limit: 3292/2000. How do I disable or raise the limit? The online help has no hits for "max feature limit" (Portal or Enterprise).

Tags (1)
1 Solution

Accepted Solutions
JonathanFarmer_oldaccount
Occasional Contributor III

Hi,

This is a limitation of the web scene viewer, done for performance reasons. However, you might consider doing a scene service as a way to move forward.

Scene services—Documentation | ArcGIS Enterprise  

Jonathan

View solution in original post

7 Replies
DanPatterson_Retired
MVP Esteemed Contributor
0 Kudos
JonathanFarmer_oldaccount
Occasional Contributor III

Hi,

This is a limitation of the web scene viewer, done for performance reasons. However, you might consider doing a scene service as a way to move forward.

Scene services—Documentation | ArcGIS Enterprise  

Jonathan

LR
by
Regular Contributor

So it can't be turned off even if I don't care about performance hits? The layer is a 3D polygon set so it wasn't possible to publish it. It did work after converting it to MP, however.

0 Kudos
JonathanFarmer_oldaccount
Occasional Contributor III

Unfortunately not. It's something that is being looked at for a future release per my understanding but I don't have any information on the latest there.

LR
by
Regular Contributor

Alright thanks, that answers the question for the moment, I guess.

0 Kudos
RobertBorchert
Frequent Contributor III

Go into the properties for your Service Properties and click on the Properties.

Change the Maximum number of records... to what you need.

BrianMcAuslan1
New Contributor

I have used aggregate to get around this limit.  

Use with caution. 

0 Kudos