Select to view content in your preferred language

GIS Server URL for ArcGIS Datastore

3340
5
Jump to solution
05-19-2020 08:55 AM
WilliamCraft
MVP Regular Contributor

I have a question about the GIS Server URL when setting up a datastore via the web interface over port 2443.  The help documentation seems to state that using any of the ArcGIS Server machines in a multi-machine site is acceptable.  I'm curious, though, if doing this would still allow for high availability in the case where one of the ArcGIS Server machines fails.  Would it be better, or required in this case, to specify a load balancer URL instead?  For example, if I have ArcGIS Server machines A and B which are behind a load balancer (no web adaptor being used here), would the GIS Server URL for setting up a datastore need to be https://loadbalancer.domain.net:6443 instead of https://machineA.domain.net:6443 or https://machineB.domain.net:6443 ?  In other words, what should the "Owning system URL" be when I perform a describedatastore?  My goal is to make sure that ArcGIS Datastore can still communicate with ArcGIS Server in the event that one of the machines in that multi-machine site fails.  Thanks in advance for your help.  Also, this is for ArcGIS Enterprise 10.7.1.  

Tags (2)
0 Kudos
1 Solution

Accepted Solutions
JonathanQuinn
Esri Notable Contributor

Internally, the Data Store figures out what machines are part of the Server site and is capable of making sure that it always communicates with available machines, regardless of what URL you use to register the Data Store. The owning system URL property when describing the Data Store doesn't indicate that Data Store will only communicate with that machine.

View solution in original post

5 Replies
JonathanQuinn
Esri Notable Contributor

Internally, the Data Store figures out what machines are part of the Server site and is capable of making sure that it always communicates with available machines, regardless of what URL you use to register the Data Store. The owning system URL property when describing the Data Store doesn't indicate that Data Store will only communicate with that machine.

StefanUseldinger
Occasional Contributor II

I noticed, that my "Owning system URL" from the relational Data Store points to a single machine while the "Owning system URL" from the tile cache DS correctly points to the internal loadbalancer balancing the Server Web Adaptors. To harmonize this, I called configuredatastore.bat and registerdatastore.bat for the relational DS, but this didn't have any effect. How can I update the configuration? Do I need

BillFox
MVP Frequent Contributor

Hello @StefanUseldinger did you have any luck with this?

0 Kudos
StefanUseldinger
Occasional Contributor II

Esri support replied the following:

The owning URL normally shows the 6443 connection if the Datastore is tied with the ArcGIS Server before the Web Adaptor is configured. If the Web Adaptor is configured with the ArcGIS Server before configuring the Datastore, then when configuring the Datastore to the ArcGIS Server this will show the Web Adaptor connection.

0 Kudos
aahiapple
New Contributor

Did you manage to fix your issue? I am having a similar issue and my relational data store is not validating. 

0 Kudos