Select to view content in your preferred language

Failed to configure the server machine...not a local server machine

13307
12
Jump to solution
04-24-2013 09:56 AM
JimmyDobbins
New Contributor III
Hello,

I have successfully installed and authorized ArcGIS Server on a virtual machine (Windows Server 2012 Standard). When launching the ArcGIS Server Setup Wizard, I get an error:
Failed to create the site. Failed to configure the server machine 'PHANTOM.LOCALDOMAIN'. Server machine 'PHANTOM.LOCALDOMAIN' is not a local server machine.


This exact sequence of errors happened on another virtual machine (Windows 2008 Data Center...named hornet) and I resolved it by modifying my hosts file as follows:

# localhost name resolution is handled within DNS itself. 127.0.0.1       localhost ::1             localhost 127.0.0.1 hornet 127.0.0.1 localhost.localdomain localhost 127.0.0.1 HORNET.LOCALDOMAIN


This configuration (and one by one, commenting out all other lines) does not work on the Server 2012 VM. I have created a firewall rule to accept all connections on port 6080, given the ArcGIS Server OS account full permissions in the c:\arcgisserver folders, rebooted, verified that I have 10.1 licenses, uninstalled and reinstalled the entire program, but all to no avail. There must be some minor difference between Windows Server 2012 and Windows Server 2008 Data Center.

Does anyone see something I may be missing or should try? The forums were helpful, but I have exhausted all of the recommendations now. Thanks in advance!
1 Solution

Accepted Solutions
JimmyDobbins
New Contributor III
Justin,

Thanks for your help, I definitely learned more about what is going on with the naming, resolution, etc. Rebuilding the VM and renaming the computer after installing ArcGIS Server did the trick. Once AGS was installed on a fresh instance of Server 2012, I created the site without the need for any configuration of the hosts file. I hope this thread helps anyone who runs into the same issue in the future.

Thanks again!

View solution in original post

0 Kudos
12 Replies
JustinRodriguez
Occasional Contributor
Hello,

I have successfully installed and authorized ArcGIS Server on a virtual machine (Windows Server 2012 Standard). When launching the ArcGIS Server Setup Wizard, I get an error:
Failed to create the site. Failed to configure the server machine 'PHANTOM.LOCALDOMAIN'. Server machine 'PHANTOM.LOCALDOMAIN' is not a local server machine.


This exact sequence of errors happened on another virtual machine (Windows 2008 Data Center...named hornet) and I resolved it by modifying my hosts file as follows:

# localhost name resolution is handled within DNS itself.
127.0.0.1       localhost
::1             localhost
127.0.0.1 hornet
127.0.0.1 localhost.localdomain localhost
127.0.0.1 HORNET.LOCALDOMAIN


This configuration (and one by one, commenting out all other lines) does not work on the Server 2012 VM. I have created a firewall rule to accept all connections on port 6080, given the ArcGIS Server OS account full permissions in the c:\arcgisserver folders, rebooted, verified that I have 10.1 licenses, uninstalled and reinstalled the entire program, but all to no avail. There must be some minor difference between Windows Server 2012 and Windows Server 2008 Data Center.

Does anyone see something I may be missing or should try? The forums were helpful, but I have exhausted all of the recommendations now. Thanks in advance!



Make your etc/hosts say this:

127.0.0.1    localhost


All the rest of the stuff in there is probably causing an issue. In general, you should have IP Addresses that repeat there. All you should need is that entry. Thanks-
0 Kudos
JimmyDobbins
New Contributor III
Thanks for the response. I tried with just "127.0.0.1 localhost" in the hosts file and got the same error message.
[ATTACH=CONFIG]23760[/ATTACH]

I have gotten ArcGIS Server installed and a site created on Windows Server 2012 before, but it was a physical machine, not a virtual machine like I am trying now. On that machine there are no entries in the hosts file (DNS handles it), so I tried that on the VM with no success. Looks like I might just be forced to stick with Windows Server 2008 Data Center.

Anyone know of any other suggestions?

Thanks!
0 Kudos
JustinRodriguez
Occasional Contributor
Thanks for the response. I tried with just "127.0.0.1 localhost" in the hosts file and got the same error message.
[ATTACH=CONFIG]23760[/ATTACH]

I have gotten ArcGIS Server installed and a site created on Windows Server 2012 before, but it was a physical machine, not a virtual machine like I am trying now. On that machine there are no entries in the hosts file (DNS handles it), so I tried that on the VM with no success. Looks like I might just be forced to stick with Windows Server 2008 Data Center.

Anyone know of any other suggestions?

Thanks!


Hello,
In the error it is stating that it thinks the name of your computer is phantom.localdomain. I am guessing that is not the name of your server. That is the problem you need to fix. If name resolution doesn't work, the site will not create correctly. From your previous post, we can determine you at least had your etc/hosts files set up incorrectly. Perhaps you should delete the agsserver folder, run an ipconfig /flushdns and check the "hostname" in cmd. I would also run a ping -a 127.0.0.1 to see if it is returning the expected value of local host. Good luck-

Justin
0 Kudos
JimmyDobbins
New Contributor III
Thanks, Justin. Those were good suggestions. Here are the results:

I ran ipconfig /flushdns and it flushed successfully
I deleted the c:\arcgisserver directory and all of its contents
At the command prompt, hostname returned "phantom" (which is the name of my computer)
At the commend prompt, ping -a 127.0.0.1 returned a ping from "phantom"

I am going to recreate the VM and not rename it to see if that makes a difference. That is the only thing I can think of at this point that was different from the Windows Server 2008 Data Server installation (I renamed the computer "hornet" after AGS was successfully installed and the site created.

Thanks again for your help, I really appreciate it!
0 Kudos
JustinRodriguez
Occasional Contributor
Thanks, Justin. Those were good suggestions. Here are the results:

I ran ipconfig /flushdns and it flushed successfully
I deleted the c:\arcgisserver directory and all of its contents
At the command prompt, hostname returned "phantom" (which is the name of my computer)
At the commend prompt, ping -a 127.0.0.1 returned a ping from "phantom"

I am going to recreate the VM and not rename it to see if that makes a difference. That is the only thing I can think of at this point that was different from the Windows Server 2008 Data Server installation (I renamed the computer "hornet" after AGS was successfully installed and the site created.

Thanks again for your help, I really appreciate it!


Thanks for the update. You could try to redo the VM if that is easy enough. One thing to note is that you should not be receiving the name of the server when running ping -a 127.0.0.1. It should return 'localhost' as a value. That tells me you are still having some kind of issue with name resolution. Anyway, I hope I helped a little bit. Please just repost if you have any questions-

Justin
0 Kudos
JimmyDobbins
New Contributor III
Justin,

Thanks for your help, I definitely learned more about what is going on with the naming, resolution, etc. Rebuilding the VM and renaming the computer after installing ArcGIS Server did the trick. Once AGS was installed on a fresh instance of Server 2012, I created the site without the need for any configuration of the hosts file. I hope this thread helps anyone who runs into the same issue in the future.

Thanks again!
0 Kudos
MatthewBrown1
Occasional Contributor
renaming the computer after installing ArcGIS Server


This worked for me on VMware Workstation 9 after getting exactly the same error. I would be interested to know if this is caused by a bug in ArcGIS, Windows Server, VMware or possibly due to improper VM cloning or template use.

FYI, using ArcGIS Server 10.1 SP1
0 Kudos
MatthewBrown1
Occasional Contributor
As a follow up, I found that there were still some issues when passing credentials from other machines (e.g. publishing services when enterprise GDBs are used).

The best solution I've found is to use sysprep with an unattended XML file to set the server name at initialisation. Here's a sample of the unattended file I used for Server 2008 R2. Note the tags: <ComputerName>ilium</ComputerName>

[HTML]<?xml version="1.0" encoding="utf-8"?>
<unattend xmlns="urn:schemas-microsoft-com:unattend">
  <settings pass="specialize">
    <component name="Microsoft-Windows-Shell-Setup" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
            <ComputerName>ilium</ComputerName>
    </component>
    <component name="Microsoft-Windows-International-Core" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
            <InputLocale>en-NZ</InputLocale>
            <SystemLocale>en-NZ</SystemLocale>
            <UILanguage>en-NZ</UILanguage>
            <UserLocale>en-NZ</UserLocale>
        </component>
  </settings>
<settings pass="oobeSystem">
        <component name="Microsoft-Windows-Shell-Setup" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
            <OOBE>
                <HideEULAPage>true</HideEULAPage>
            </OOBE>
        </component>
    </settings>
</unattend>
[/HTML]

I then called sysprep from the command line:

sysprep /generalize /oobe /shutdown /unattend:C:\Windows\System32\Sysprep\sysprep.xml
0 Kudos
RichardWatson
Frequent Contributor
Today, I encountered the problem discussed in this thread when installing ArcGIS Server on a new machine.  I've installed it on many machines with no problems but not today.

For reasons unknown to me, ArcGIS Server was looking for "MachineName.localdomain" where MachineName was the name of my machine.  hostname and ping worked fine.  I also deleted C:\arcgisserver, hacked at the hosts file, ran ipconfig /flushdns, and rebooted many times to no avail.

What I finally did was the following:

  1. Renamed my machine to only use letters (I had both/only letters and numbers in my original name).  I haven't a clue whether or not this step was needed/relevant but I know from other posts that ArcGIS Server has (or had) some issues with special characters.  I figured that numbers were OK but was not sure.

  2. Rebooted

  3. Deleted C:\arcgisserver

  4. Hand edit all files in C:\Program Files\ArcGIS\Server which had MachineName.localdomain to use just the new server name



The files that I had to manually edit were:

C:\Program Files\ArcGIS\Server\framework\etc\machine-config.xml
C:\Program Files\ArcGIS\Server\geronimo\var\config\config-substitutions.properties

To come clean here, I must mention that I did all of this on Windows 8.1 (yes I know that it is not yet supported).

FWIW, this is a stand-alone machine which is not a member of any domain.