Error: Failure to access the DBMS server [[Microsoft][SQL Server Native Client 11.0]Communication link failure]

2282
2
01-15-2017 07:46 AM
JayHalligan
New Contributor II

I am getting this error from ArcGIS Server logs after publishing and SDE Database.  I can edit and view the data in Desktop but after I publish and try to view the service in AGOL I get errors.  I recently upgraded to Desktop 10.5.  This  seems to happen with all newly created SDE databases.  Older SDE databases publish fine when creating new feature classes.   When I open in AGOL I can see the feature database table but I do not see the geoometry features.  No errors on publishing only when accessing the service.

Here are a few of the errors in ArcGIS Server Logs:

There is an error during the draw Manholes (1.) DBMS table not found [42S02:[Microsoft][SQL Server Native Client 11,(2.) 0][SQL Server]Invalid object name 'DASNY,(3.) DBO,(4.) SDE_GEOMETRY2',(5.) ] [DASNY,(6.) DBO,(7.) Manholes].

There is an error drawing layer: Manholes

0 Kudos
2 Replies
JordanPorter
New Contributor III

Did you ever resolve this?  I am having the same issue.  Just upgraded to 10.5, new service wont draw.  I can query and return results, view the table in AGOL, etc.  but it will not draw and gives the error There is an error drawing layer: <layer_name>

0 Kudos
RebeccaStrauch__GISP
MVP Esteemed Contributor

Have you checked to make sure you SDE Enterprise database is still supported? 

ArcGIS Server 10.5 system requirements—Installation Guides (10.5) | ArcGIS Enterprise 

I know we use SQL2008 still, and it specifically mentions that that is no longer supported for creating new SDE databases (and I'm hesitant to edit on previously created databases....but I have not tested editing of using with ArcGIS Server yet.)

0 Kudos