edits not being moved to base tables after compression

1392
4
06-23-2017 05:53 AM
ErikBlake
Regular Contributor

we have 10.3.1 our field guys are using collector for hydrant flushing program. they are editing directly to our sde default versioned database. for some reason when i do our nightly compression of the database their edits are not showing up in the base tables. they are staying in the delta tables. this problem seems to have just started. it was working last week. any ideas what might be causing this?

4 Replies
George_Thompson
Esri Frequent Contributor

It sounds like there is a blocking version in the GDB that has not been Reconciled/Posted yet.

https://community.esri.com/groups/geodatabase?sr=search&searchId=8cebf85a-f755-4229-8734-4113903f412...

--- George T.
0 Kudos
ErikBlake
Regular Contributor

George

Thanks for the reply. We don't have any versions created from our default. So not sure what would need to be reconciled and posted. We do have multiple one way replications that are childs of our default. would that cause it to behave like this?

0 Kudos
George_Thompson
Esri Frequent Contributor

That may be possible. Here is a white paper talking about replicas and the compress. I know it is old, but still applies.

http://downloads.esri.com/support/whitepapers/ao_/J9842_GDB_Compress_With_Replicas.pdf 

Update: What changed between last week (when the compress move the edits to the base table) and now?

--- George T.
0 Kudos
ErikBlake
Regular Contributor

George 

So i figured out that i had to stop the map services that are hitting our default database. Just disconnecting them using the admin window in catalog was not enough.