Select to view content in your preferred language

Configure ArcGIS DataStore 10.9.1 Error connecting to ArcGIS Server Machine

1526
6
03-13-2022 11:11 PM
RedaAli
New Contributor III

I'm trying to configure ArcGIS DataStore 10.9.1 installed  on windows server 2019

with ArcGIS server Machine on Win2019. it is failed with error:

Could not connect to server on machine 'https:\\GISSERVERFQDN:6443'. ArcGIS Data Store or ArcGIS Server on that machine may not be running or the machine is not reachable at this time.

however, ArcGIS Server Machine is running and can connect to it on the browser.

 

0 Kudos
6 Replies
Scott_Tansley
MVP Regular Contributor

Hi.  At 10.9.1 you don’t need to put the https or the port number it’s just the fully qualified domain name of the proposed hosting server:

   hostname.domain.com

do not use the web adaptor address.  It’s purely the name of the host machine.

also make sure you’re using the primary site admin account for the server.  Don’t use portal credentials?

also have you opened up all the firewalls?

Scott Tansley
https://www.linkedin.com/in/scotttansley/
0 Kudos
RedaAli
New Contributor III

Hi Scott.

 Thanks for your clarifications .

  • for using the hotsname.domain.com , I think this help page from ESRI stated to use the port and https, However the help is for 10.9.1, Also I tried the server FQDN without https & port and returned the same error

https://enterprise.arcgis.com/en/portal/latest/administer/windows/troubleshoot.htm#anchor1

  • I'm using the purely FQDN of the ArcGIS server machine.
  • could you please define which port shall be opened and is it only 2443,9876 for datastore?
0 Kudos
Scott_Tansley
MVP Regular Contributor

I think that may be out of date.  We had to enter:

    https://host.domain.com:6443

up until and including 10.7.1 but since then I have only ever entered:

   host.domain.com 

The web configuration form actually states:

   Example:  gisserver.domain.com

I've seen people enter http://...:6443 and it fail, so stick to the example.

Which data stores are you installing on this machine?  There are different ports for each data store type.  Documentation is here:

   Ports used by ArcGIS Data Store—ArcGIS Enterprise | Documentation for ArcGIS Enterprise

 

Scott Tansley
https://www.linkedin.com/in/scotttansley/
0 Kudos
EmilyKnippel
New Contributor II

What was your solution to this? I'm having the same issue even with entering host name and admin credentials. Thanks!

0 Kudos
ScottTansley3
New Contributor III

Hi Emily,

In the past we used:

   https://host.domain.com:6443

in the data store config, but only up and including ArcGIS 10.7.1.

Since then I have only ever entered:

   host.domain.com 

The configuration tools adds the https:// and the :6443  if you try and enter the full path into the configuration screen then my guess is that behind the scenes it's trying to connect to:

   https://https://host.domain.com:6443:6443

which is clearly wrong.  Stick to the host.domain.com approach and you should be fine.

0 Kudos
MatthewRyan2
New Contributor III

I had this same issue and resolved it with the following approach.

My normal hosting server URL is like this: https://gis-prep.orgname.com

Here is what I tried (note that browsing to the site via web browser worked):

  1. https://gis-prep.orgname.com and https://gis-prep.orgname.com/arcgis
  2. https://hostname.orgname.com and https://hostname.orgname.com/arcgis
  3. The above 1 and 2 with port specified 6443
  4. gis-prep.orgname.com and gis-prep.orgname.com:6443
  5. gis-prep (THIS WORKED)

So there you have it, with all the morning fluffing about, it works via "gis-prep" as the hosting server name.

Hope that helps some people.

Helpful Info:

This was an upgrade from Enterprise 10.8.1 to 11.1. 

0 Kudos