Can you use the Adopta web app with ArcGIS server and desktop 10.4 or does it have to be 10.4.1? Also, is it fairly easy to use it for hydrants rather than the included catch basin mxd?

1494
17
12-30-2016 05:58 AM
DarylHochhalter
Occasional Contributor

I noticed the instructions show 10.4 when installing ArcREST, but not sure that the upgrade to 10.4.1 would change that.

0 Kudos
17 Replies
AnthonyKobah
Occasional Contributor

Hi Daryl,

Could you share the instructions you are referring to or a link to it?

Thanks

0 Kudos
DarylHochhalter
Occasional Contributor
0 Kudos
RandallWilliams
Esri Regular Contributor

This solution *SHOULD* work with 10.4, but I make no guarantees. It looks to be pretty straight forward - you don't even have to change the schema in the sample GDB provided.

In fact the schema is exactly the same, the only difference is the name of the service:

Hydrants:

http://services6.arcgis.com/Pu6Fai10JE2L2xUd/arcgis/rest/services/Hydrants/FeatureServer/0/

CatchBasins:

http://services6.arcgis.com/Pu6Fai10JE2L2xUd/arcgis/rest/services/CatchBasins/FeatureServer/0/

This example is slightly different because the geometry type is polygon, but the fields are named the same:

Parks:

http://services6.arcgis.com/Pu6Fai10JE2L2xUd/arcgis/rest/services/Park/FeatureServer/0

0 Kudos
AnthonyKobah
Occasional Contributor

I'm yet to see an upgrade change the folder from 10.4 to 10.4.1 in C:\Python27\. You should be good with it the desktop one but make sure the x64 (C:\Python27\ArcGISx6410.4) is used for the server install 

0 Kudos
DarylHochhalter
Occasional Contributor

Thanks so much for your input on this topic, it does appear to be working with version 10.4. I haven't gotten all the bugs out of the Adopta App I deployed but don't think they are related to Server Version.

0 Kudos
ChrisBuscaglia
Esri Contributor

@Daryl.Hochhalter

This is Chris Buscaglia from the Local Government Solutions team. 

Please let me know if you need any help configuring the application, I can assist you with that.


Chris

0 Kudos
DarylHochhalter
Occasional Contributor

I think that I have it really close, changed the email templates to reference hydrants and renamed the layer. Everything seems to be working independently, until I put it together in the Web Appbuilder (developer edition). At that point when I enter an email to signup/login I get a generic error "unable to complete operation". I think it must have something to do with the AuthGP service. An entry is never made in the usertable and an email is never sent. The AuthGP service does run in Arcmap before publishing the service. Any ideas would be appreciated.

0 Kudos
ChrisBuscaglia
Esri Contributor

ArcREST installed on the ArcGIS server machine hosting the GP service?

If so, we may need to do a quick screen share to triage it - send me a email at cbuscaglia@esri.com and we can continue the conversation.

0 Kudos
DarylHochhalter
Occasional Contributor

FYI, It turns out that after some testing there are issues that make it impossible for the app to access the user table without an upgrade to at least 10.4.1. Thanks for all the help!

0 Kudos