ArcMap 10.4 "Share As A Service" Hanging

537
2
Jump to solution
08-18-2016 06:07 AM
SteveBurdette
Occasional Contributor

I've installed several ArcMap servers and until this latest install have had no issue publishing web services from ArcMap to ArcGIS for Server.  I have a Windows Server 2012 R2 Standard with SQL Server 2014 and ArcGIS Server 10.4 installed.  From ArcMap 10.4 I am able to connect to the database and view data in a point feature class.  When I choose "File->Share As Service..." and choose "Publish a service" from the first dialog, I then choose my server connection and give the service a name.  On the third dialog, I'm able to choose the "Use existing folder" option and choose the folder that I created using Server Manager.  When I click "Continue" from this dialog, the dialog never returns and I eventually have to end the task using Task Manager.  

I'm not seeing any helpful error logs on the server and have not had any issues publishing services until now.  I've install ArcMap desktop 10.4 on the server and I get the same response when trying to share the feature class as a web service.  

Any ideas?

0 Kudos
1 Solution

Accepted Solutions
JakeSkinner
Esri Esteemed Contributor

Hi Steve,

Try installing the following patch to see if it resolves this issue:

ArcGIS for Server Publishing Patch 

View solution in original post

2 Replies
JakeSkinner
Esri Esteemed Contributor

Hi Steve,

Try installing the following patch to see if it resolves this issue:

ArcGIS for Server Publishing Patch 

View solution in original post

SteveBurdette
Occasional Contributor

The patch worked like a charm.  Thanks so much for the quick response.

0 Kudos